[1.31.0-wmf.3] False 'Missing in English' label is displayed for articles existing in enwiki
Closed, ResolvedPublic

Description

This bug is consistently present in different language wikis. Here are the steps to reproduce the issue (enwiki used as example):

  1. Go to the main page of your preferred wiki.
  2. From the top-right navigation bar hover over "Contributions" and choose "Translations".
  3. Open "New translation" dialog.
  4. Choose the source language to be same as current wiki you are on (for enwiki, it would be English, for ruwiki - Russian, etc...).
  5. Reload the page.
  6. Open "New translation" dialog again.
  7. Now, there are two ways to see the issue:
    • If you have some recent edits, articles you've edited recently would display when you open the dialog, where you can see the issue.
    • If you don't have any recent edits, just enter something in search input bar (e.g. "Japan" or "Robot")

Here are some screenshots showing the issues, where source and target language are the same, which leads to labels like "Missing in English" showing, even though you are searching for pages in English Wikipedia.


ruwiki displays articles that exist but, with the label "Missing in Russian".

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 12 2017, 11:01 PM

Change 385179 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Fix same source and target language

https://gerrit.wikimedia.org/r/385179

Arrbee moved this task from Bugs to Oct-Dec 2017 on the ContentTranslation board.Oct 27 2017, 6:17 AM
santhosh updated the task description. (Show Details)Oct 31 2017, 5:10 AM

Change 385179 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Fix same source and target language

https://gerrit.wikimedia.org/r/385179

Checked in enwiki (wmf.6) and cx-testing - the issue is fixed.

Etonkovidova closed this task as Resolved.Nov 3 2017, 10:28 PM
Nikerabbit moved this task from QA to Done on the Language-2017-Oct-Dec board.Nov 7 2017, 7:04 AM
Petar.petkovic reopened this task as Open.Nov 11 2017, 5:29 PM
Petar.petkovic moved this task from Done to Backlog on the Language-2017-Oct-Dec board.
Petar.petkovic triaged this task as Normal priority.

Reopening the ticket because this bug isn't resolved, found it again in production.

Change 390997 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Fix same source and target language

https://gerrit.wikimedia.org/r/390997

Change 390997 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Fix same source and target language

https://gerrit.wikimedia.org/r/390997

@Petar.petkovic: The fix seems to be working - and besides, it is not possible to have a situation when you have, for example, English->English translation in New translation dialog:
(the screenshot is from wmf.7)

However, checking cawiki (wmf.8) I saw a tricky case of incorrect "Missing in English" displayed. It could be a different issue.
Steps to reproduce:

  1. On cawiki, repeat the steps listed in this ticket
  2. After typing, for example, "Robot" in step #7 (and see the correctly displayed suggestions), press the spacebar to add a white space - a strange entry for Robot article will be displayed with "Missing in English".

The screen recording shows that for catala->English suggested translations, Robot article becomes marked with "Missing in English" after adding a white space in the text field. When I click on it, I see "The article already exists in English".


This extra article item appears with many search entries - e.g. Tor, Japan, Test. After clicking on such suggestion, you'll redirected to the article that was displayed below on the list.

The link associated with the extra item is exactly the same:

<div class="oo-ui-widget oo-ui-widget-enabled oo-ui-labelElement oo-ui-optionWidget oo-ui-iconElement oo-ui-decoratedOptionWidget oo-ui-menuOptionWidget mw-widget-titleOptionWidget mw-cx-widget-titleOptionWidget" aria-disabled="false" tabindex="-1" role="option" aria-selected="false" id="oojsui-8"><span class="oo-ui-iconElement-icon oo-ui-icon-page-existing"></span><a class="oo-ui-labelElement-label"** href="//ca.wikipedia.org/wiki/Robot_" **tabindex="-1" title="Robot">Robot</a><span class="oo-ui-indicatorElement-indicator"></span><span class="mw-cx-widget-titleOptionWidget-numOfLanguages"><span class="oo-ui-widget oo-ui-widget-enabled oo-ui-iconElement oo-ui-iconElement-icon oo-ui-icon-language oo-ui-iconWidget" aria-disabled="false" title="Number of languages"></span><label class="oo-ui-widget oo-ui-widget-enabled oo-ui-labelElement oo-ui-labelElement-label oo-ui-labelWidget" aria-disabled="false">1</label></span><span class="mw-cx-widget-titleOptionWidget-missing">Missing in English</span></div>

And for the below item, some image will be included:

<div class="oo-ui-widget oo-ui-widget-enabled oo-ui-labelElement oo-ui-optionWidget oo-ui-iconElement oo-ui-decoratedOptionWidget oo-ui-menuOptionWidget mw-widget-titleOptionWidget mw-cx-widget-titleOptionWidget" aria-disabled="false" tabindex="-1" role="option" aria-selected="false" id="oojsui-9"><span class="oo-ui-iconElement-icon oo-ui-icon-page-existing mw-widget-titleOptionWidget-hasImage" style="background-image: url(&quot;https://upload.wikimedia.org/wikipedia/commons/thumb/8/80/Paris_Air_Show_2007-06-24_n20.jpg/80px-Paris_Air_Show_2007-06-24_n20.jpg&quot;);"></span><a class="oo-ui-labelElement-label"** href="//ca.wikipedia.org/wiki/Robot" **tabindex="-1" title="Robot">Robot</a><span class="oo-ui-indicatorElement-indicator"></span><span class="mw-widget-titleOptionWidget-description" title="mechanical or virtual artificial agent">mechanical or virtual artificial agent</span><span class="mw-cx-widget-titleOptionWidget-numOfLanguages"><span class="oo-ui-widget oo-ui-widget-enabled oo-ui-iconElement oo-ui-iconElement-icon oo-ui-icon-language oo-ui-iconWidget" aria-disabled="false" title="Number of languages"></span><label class="oo-ui-widget oo-ui-widget-enabled oo-ui-labelElement oo-ui-labelElement-label oo-ui-labelWidget" aria-disabled="false">107</label></span></div>

That bug is related to how search results are added while user types the query. After query results are fetched from server, one additional result is added as first result, matching the exact user input. So, the same problem would be surfaced if you use lowercase "robot", with or without the space character after the letters.

This is inherited from OOJS UI widget's way of processesing results. The ticket for which this behavior may have been introduced is this one: T50476: VisualEditor: MWLinkTargetInputWidget should grok case sensitivity of suggested page title vs. the inputed text.

@Etonkovidova, we have already discussed this addition of exact user input during offsite. Thank you for reporting it, I will look into fixing the issue.

Etonkovidova closed this task as Resolved.Nov 20 2017, 9:52 PM

The issue with a duplicate suggestion is filed as a separate issue: T181002: Duplicate suggestion when a white space is added to the search criteria

Nikerabbit moved this task from QA to Done on the Language-2017-Oct-Dec board.