Page MenuHomePhabricator

language selector (interlanguage links) on the Minerva main page is different from other pages
Open, LowPublic

Description

The main page in mobile view has no language selection icon at the top. Instead the language button is at the bottom of the page. It's contextual more than inconsistent.

The treatment is different on the main page as the main page does not show a title or page actions bar.
Many main pages are designed very differently from other pages, for example Hindi Wikipedia:

Showing a page actions bar on the main page has a variety of problems, which vary depending on the wiki:

To take Hindi Wikipedia as an example:

  • On Hindi Wikipedia, black icons on gray background (accessibility problems not easily fixed by making white background alongside gray)
  • Edit icon that will always be locked (given most main pages are protected)
  • Surplus unnecessary information - e.g. "Main page"
  • Redundant features (it is useful to watch the main page given it is protected?)
  • If language icon is the only feature, could push down more useful content

To quote @Nirzar

... main page design has a lot more problems than just language selection.

We can design a better experience for language selection and other relevant page actions for main page but they are likely to be deprioritized because we are a small team

I can design a better solution if anyone else is interested in building it

Event Timeline

Amire80 created this task.Oct 27 2017, 11:56 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 27 2017, 11:56 AM
Jdlrobson added a subscriber: Jdlrobson.

This might be by design. I can't recall whether we decided to show the button at bottom of page or not show it at all. No page actions in Minerva skijn.

If it's by design, I'd love to know the rationale.

not by design, it was at the bottom of the page saying "read in other language". maybe regression?

Jdlrobson added a comment.EditedOct 31 2017, 12:36 AM

Weird.. now when I test this locally I do see the main page button. Likewise I see it on https://en.m.wikipedia.org/wiki/Main_Page

@Amire80 where are you not seeing it...?

Oh, OK, I do see it at he bottom. But why is it different from other pages?

Jdlrobson closed this task as Invalid.Oct 31 2017, 5:31 PM

There is no page actions (top bar) on main page. This /is/ by design - given the majority of editors do not have permission to edit the main page and have little motivation to watch the main page and the main page is visually different where the primary purpose is access to content not editing content.

Amire80 reopened this task as Open.Oct 31 2017, 5:37 PM

I get it that people are unlikely to edit the main page on mobile, but aren't they likely to want to switch to a different language? And if so, why make it inconsistent with other pages?

Amire80 renamed this task from There is no language selector on the main page in mobile web view to language selector on the mobile main page is different from other pages.Oct 31 2017, 5:37 PM

it's contextual more than inconsistent.

Also, main page design has a lot more problems than just language selection.

We can design a better experience for language selection and other relevant page actions for main page but they are likely to be deprioritized because we are a small team

I can design a better solution if anyone else is interested in building it

Jdlrobson triaged this task as Low priority.Oct 31 2017, 7:52 PM
Jdlrobson removed a project: User-Jdlrobson.
Nirzar changed the task status from Open to Stalled.Nov 9 2017, 3:17 AM
Jdlrobson renamed this task from language selector on the mobile main page is different from other pages to language selector (interlanguage links) on the mobile main page is different from other pages.Jun 18 2018, 11:45 PM
Jdlrobson renamed this task from language selector (interlanguage links) on the mobile main page is different from other pages to language selector (interlanguage links) on the Minerva main page is different from other pages.
Amire80 changed the task status from Stalled to Open.Jun 19 2018, 7:36 AM

@Jdlrobson, thanks for merging T197548 :) I remembered reporting this task here, but couldn't find it for some reason.

More generally, I still don't understand why does the language selection on the main page have to be different in any way from how it works on other pages.

Jdlrobson updated the task description. (Show Details)Jun 19 2018, 7:04 PM

I've had a go at explaining how I understand this (mostly from a technical POV and experience) in the description. My understanding is given the variance of main page designs across all our projects having a consistent and enjoyable experience is extremely hard and a lot of effort and we'd need to audit and have bespoke solutions for many of them and this simply hasn't been prioritised highly.

Restricted Application added a subscriber: Masumrezarock100. · View Herald TranscriptJan 17 2020, 10:57 PM