Page MenuHomePhabricator

References disappear after publishing translation
Closed, ResolvedPublic

Description

I was translating the article "Hugo de Jonge" from Dutch to English using the Content translation tool. After painfully rearranging the references (this is unfortunately a Hard Thing), they suddenly disappeared after clicking 'publish'. Not a trace can be found in the wikitext that was published. In the translation tool they were still visible.

Enwiki (first version): https://en.wikipedia.org/w/index.php?title=Hugo_de_Jonge&oldid=809114312
nlwiki: https://nl.wikipedia.org/w/index.php?title=Hugo_de_Jonge&oldid=50285013

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 7 2017, 5:46 AM
Halibutt added a subscriber: Halibutt.EditedDec 6 2017, 12:35 AM

Ok, another example of the very same thing happening. Steps to reproduce:

  1. Open article on [[Caffeine citrate]] from en.wiki for translation to Polish (using Yandex, or any other method for that matter).
  2. Translate,
  3. Publish to draft,
  4. Result is this (two references malformed, the rest of them deleted altogether).

BTW, the list of my gadgets and scripts is available in T179633 in case it mattered.

Checked "Caffeine citrate" en->pl translation - Result.
The mangled references will be displayed when switching to VE, stating that they can be edited only in source text.
The read mode:


Switching to VE:

The wikitext code:

== Zastosowanie medyczne ==
Cytrynian kofeiny jest preferowanym lekiem w leczeniu bezdechu pierwotnego u wcześniaków<ref />. W porównaniu z [[Teofilina|teofiliną]] rzadziej powoduje skutki uboczne<ref />.

Cytrynian kofeiny działa w podobny sposób do samej kofeiny, jednak działa o wiele szybciej, szybciej się także dysocjuje. Podobnie jak kofeina może być także pomocny w zwalczaniu bólów głowy, jednak w przypadku ostrych [[Migrena|migren]] stosuje się raczej połączenie kofeiny i [[Benzoesan sodu|benzoesanu sodu]].

The main question is why wikitext code ended up incorrectly formatted. Unfortunately, I cannot reproduce the issue in cx2-testing or cx-testing. All references will be published as they were translated. Could be there some re-arranging references steps that are not described in the "Steps to reproduce"?

Etonkovidova removed Etonkovidova as the assignee of this task.Jun 15 2018, 12:38 AM
Etonkovidova added a subscriber: Etonkovidova.
Arrbee closed this task as Resolved.Jun 25 2018, 2:49 PM
Arrbee claimed this task.
Arrbee added a subscriber: Arrbee.

Checked by Elena. Possibly resolved due to ongoing work.