Page MenuHomePhabricator

Logo text cannot be converted into local language version
Closed, ResolvedPublic

Description

The four words appearing in the top left hand corner : "維基百科", when viewed in Timless skin, cannot be correctly converted to local language glyph version. It remains in a simplified font when the page language is set into Traditional Chinese glyph (zh-hant , zh-hk , zh-mo , zh-tw ).

Event Timeline

1233thehongkonger updated the task description. (Show Details)
TheDJ removed 1233thehongkonger as the assignee of this task.Nov 24 2017, 8:22 AM

Change 393221 had a related patch set uploaded (by Jack Phoenix; owner: Jack Phoenix):
[mediawiki/skins/Timeless@master] LanguageConverter support for [[MediaWiki:Timeless-sitetitle]]

https://gerrit.wikimedia.org/r/393221

Change 393221 merged by jenkins-bot:
[mediawiki/skins/Timeless@master] LanguageConverter support for [[MediaWiki:Timeless-sitetitle]]

https://gerrit.wikimedia.org/r/393221

The release did not fix the title problem. Please refer to the following link: https://zh.wikipedia.org/w/index.php?title=Wikipedia:%E9%A6%96%E9%A1%B5&variant=zh-hant&useskin=timeless
Please confirm it with others of Traditional Chinese Editors.

Surprising to see that the patch didn't fix it, but that indeed appears to be the case. Here's a slightly different comparison for us who are not so well versed in Chinese, using the Serbian (sr) Wikipedia as an example: sr.wikipedia main page with variant=sr-ec (Cyrillic) vs. sr.wikipedia main page with variant=sr-el (Latin).
In both cases, #p-banner's text is Википедија, though it should be this only for the Cyrillic variant and for the Latin variant it should be Vikipedija.
This appears to be easily reproducable and not dependent on the user's login state.

@cscott, would you happen to have any idea as to what's going on? (I recall that you did some work on LanguageConverter in the past, hence the question as there aren't many people around who are familiar with the inner workings of LanguageConverter.)

Removed the project of Chinese-Sites as it seem to affect more than one language version - for the cyrillic users - ja we get the same problem

@1233thehongkonger Note that we do have Serbian-Sites now, which also have somewhat some roles in this matter, will this be a reason that you re-add that tag, with together adding Serbian-Sites tag?

Isarra added a subscriber: Isarra.Jan 15 2019, 3:53 AM

Well, it does seem to be working in serbian now, since that was what I was using to test for T213578 (the general underlying issue).

I don't even know.

Isarra closed this task as Resolved.Aug 16 2019, 5:44 PM
Isarra claimed this task.

Please come back and complain (again, sorry) if I'm wrong, but some basic testing on sr and zh does indicate it seems to now be working properly.