Page MenuHomePhabricator

Search results from sister site are always aligned under the main results
Closed, ResolvedPublic

Description

The search results from sister sites are aligned underneath the main search results. This seems consistent across all various width variants.

Details

Related Gerrit Patches:

Event Timeline

TheDJ created this task.Nov 24 2017, 10:44 AM

Example URL of the problem: https://en.wikipedia.org/w/index.php?title=Special:Search&search=timeless&fulltext=Search&useskin=timeless

Seems to be caused by .mw-searchresults-has-iw #mw-interwiki-results having an additional, unnecessary and unwanted margin-left: 8% -- removing that makes the problem go away and the search results look nice 'n' tidy (at least on my setup: IE11/Win7, 1440x900px screen resolution).

@Isarra @matmarex Thoughts? Should I just apply something like .mw-searchresults-has-iw div#mw-interwiki-results { margin-left: 0%; } to Timeless' screen-common.less in order to fix this?

TheDJ added a comment.EditedNov 24 2017, 7:19 PM

Actually no that one is intentional. This is because the <ul> element has --webkit-padding-start: 40px. I'm assuming IE has similar implicit user agent styling.

On vector, we force all ul elements to padding:0 explicitly, but not with Timeless, there we only force it to 0 on: .mw-content-ltr ul
But search results are not inside .mw-content-ltr, we should probably change that to reflect the entire content area of timeless, and not just to rendered wikicode fragments.

Also, seems the normalise.css library isn't entirely complete :)

Amire80 moved this task from Backlog to Bugs on the Timeless board.Dec 5 2017, 10:15 AM
matmarex removed a subscriber: matmarex.Apr 5 2018, 3:02 PM

Change 428284 had a related patch set uploaded (by Evad37; owner: Evad37):
[mediawiki/skins/Timeless@master] Add explicit padding and margins for all ul elements

https://gerrit.wikimedia.org/r/428284

Change 428284 merged by jenkins-bot:
[mediawiki/skins/Timeless@master] Add explicit padding and margins for all ul elements

https://gerrit.wikimedia.org/r/428284

Evad37 closed this task as Resolved.May 9 2018, 1:14 AM
Evad37 claimed this task.