'Number of edits to show...' option on Recent Changes preference page shows the wrong descriptive text
Closed, ResolvedPublic

Description

On the preference tab for Recent Changes, the # of edits to show option is described this way:

  • Number of edits to show in recent changes, page histories, and in logs, by default:

Which is fine. But below that is a line of descriptive text, in a smaller font, that says:

  • This includes recent changes, page histories, and logs.

Obviously, this is redundant. The instruction text should be the same as on Watchlist, where it indicates the maximum allowable number, 1000. Please change the text to:

  • Maximum number: 1000
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 15 2017, 8:34 PM
jmatazzoni updated the task description. (Show Details)Dec 15 2017, 8:43 PM

Should we say that have a high number to display will slowdown the results display?

! In T183030#3847813, @Trizek-WMF wrote:

Should we say that have a high number to display will slowdown the results display?

Hmm. In theory, not a bad idea. But in practice, I can't think of a phrasing that doesn't look peculiar. E.g.:

  • Maximum number: 1000 (selecting the maximum may slow performance)
  • Maximum number: 1000 (search may be slower when the maximum is selected)

May have that information behind a Question mark icon?
that kind of icon exists on OOui, but I don't know if that's the case for the current (bad) design implemented.

The reason why we have such redundancy is because this particular message is customized on enwiki. Last change to customized message on enwiki happened back in 2008, when there was probably no help text below to say This includes recent changes, page histories, and logs.
Base message (without customization) was "Titles in recent changes" back then and now it is "Number of edits to show by default:".

We could make following changes to default messages:

Current defaultProposed default
Number of edits to show by default:Number of edits to show in recent changes, page histories, and in logs, by default:
This includes recent changes, page histories, and logs.Maximum number: 1000

Change 399673 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/core@master] Change Recent Changes "Number of edits..." preference message

https://gerrit.wikimedia.org/r/399673

This is the how it looks with English UI after the change:

I would argue this bug report is actually invalid, because the issue is not in the MediaWiki software, but in a local override that only exists in the English Wikipedia: https://en.wikipedia.org/wiki/MediaWiki:Recentchangescount. Simply delete this local page and the issue is resolved.

I can not support the proposed patch because it makes the label way to long, and wrap in ugly ways, especially when enlarging the font size:

This is how it is supposed to look, for comparison:

Change 399673 abandoned by Petar.petkovic:
Change Recent Changes "Number of edits..." preference message

Reason:
As per multiple suggestions, this should be resolved on enwiki by removing custom message.

https://gerrit.wikimedia.org/r/399673

Petar.petkovic added a subscriber: Catrope.

As this problem was uncovered because of customization to message on enwiki, it should be solved over there. @Catrope claims to have rights to delete customized message that causes redundancy in main message and help text.

@thiemowmde, I certainly see what you mean in saying the label is long. But which pages the option controls is a highly relevant piece of info that users selecting the option will want to know. Putting it right in the name of the option is a great way to bring it forward.

Also, the version you show as how the option is supposed to look is an imperfect comparison, since it does not include the info, which we would like to include, about maximum number allowable. By the time you put that in, the difference in length is minimal. Let's stick with the plan. And yes, @Catrope should delete the English modification, which is no longer necessary.

Change 399673 restored by Petar.petkovic:
Change Recent Changes "Number of edits..." preference message

Reason:
We still might do this.

https://gerrit.wikimedia.org/r/399673

@jmatazzoni, I don't get what you want to say.

There is not much value in repeating the maximum number. This is a purely technical information that is irrelevant to 99.99% of the users, and does nothing but adding noise to the page. The limit is technically enforced anyway. The numeric input does have an actual upper limit that becomes obvious the moment the user hits it.

If you insist on changing the label, please skip all the filler words in the currently proposed message, and make it as short as possible: "Default number of edits in recent changes, histories, and logs: …"

Is the expected results still this?

If so, I don't see any repetition in it.

What about saying that increasing that default number will slow down the display of results?

Is the expected results still this?

That is how it looks with my proposed change, which is still not merged (accepted).

What about saying that increasing the number will slow down the display of results?

What about saying that increasing the number will slow down the display of results?

Since you already asked same question, and I was only one who wrote comment afterwards, I assume you ask me, since I haven't answered on that one.

The proposal is open, but @jmatazzoni already wrote how it's hard to come up with good language to communicate such information. I would like to draw attention to how long the UI messages will be, if we decide to include such additional info. Localized messages will be even longer, in most cases.

Whatever we decide, WL should be kept in sync.

What do we want from this? Is there any consensus? Or should I just abandon the patch that brings the change?

Yes. Please make it like this;

Thanks Petar.

Yes. Please make it like this:

Ok, patch to make that change is out there (and waiting for two months). I will ping @Catrope and @SBisson to take a look.

Etonkovidova closed this task as Resolved.Mar 9 2018, 5:13 PM
Etonkovidova claimed this task.

Checked in betalabs:

QA Recommendation: Resolve