Page MenuHomePhabricator

Bug in Basque Wikipedia Visual Editor
Closed, InvalidPublic

Description

Hi Sage, sorry if you are not the right person, I do not to whom this applies! Since about 10 days ago, I am going through certain issues at the Visual Editor (Ikusizko Editorea) at the Basque Wikipedia, tab "Aldatu" (an option enabled in regular articles). When I add a link after selecting it on a word or phrase, it is not implemented on the text selected, but partially out of the defined text.

Sometimes a parasite link may appear diving a word, mirroring a previous existing link. Also when I try to insert a reference somewhere in the text, after I have filled out the data in the provided form, it fails to appear where one places the cursor, instead diving the word next-by or in another place. This is a real nuisance and makes Visual Editor impractical. The first time may not happen anything strange, but as one keeps adding links or references, the problem builds up.

The issue takes place from different accounts, different computers and different people, although seem not to have noticed the issue in the community discussion.

Event Timeline

Mvolz removed Ragesoss as the assignee of this task.Feb 19 2018, 10:30 AM
Mvolz added a project: VisualEditor.
Mvolz added a subscriber: Ragesoss.
Inaki-LL edited projects, added Bug-Report; removed Wikimedia-User-Group-Basque.
Inaki-LL updated the task description. (Show Details)
Theklan removed Ragesoss as the assignee of this task.Feb 19 2018, 11:52 AM
Theklan removed a subscriber: Ragesoss.
Deskana changed the task status from Open to Stalled.Feb 20 2018, 7:38 PM
Deskana added a subscriber: Deskana.

I can't reproduce this problem. Please provide exact steps to reproduce, including the specific article you edited, the specific text you highlighted, and so on.

You may also want to read the documentation about locating broken scripts. :-)

I can't reproduce it either, but I saw it happening in an specific computer in a university course. AS the computer was private, I couldn't retrieve the data, and I suggested not to save it, as it would be taken as invalid edition.

I can't reproduce it either, but I saw it happening in an specific computer in a university course. AS the computer was private, I couldn't retrieve the data, and I suggested not to save it, as it would be taken as invalid edition.

Were they using the visual editor? There are some text highlighting issues, that can cause highlighting to not appear aligned with text, that happen when the user is using the 2017 wikitext editor and syntax highlighting extensions together, but not in the visual editor.

Theklan added a comment.EditedFeb 20 2018, 9:28 PM

Yes, AFAIK. On the other hand, they were new users so they didn't have syntax highlighting enagled.

@Deskana I went through this issue with my username in different web browsers (Firefox and Chrome). Also I tried it (and double-checked it right now) with different accounts, and the issue remains there. A student in a university building (operating system Windows Microsoft) also drew my attention to this dysfunctional behaviour in the Visual Editor. The sample is wide enough to think it is not related to a specific place or account, as far as I see it.

@Inaki-LL That's useful information. That said, I must repeat my request from T187699#3987123 for specific reproduction steps, as I am still unable to reproduce the issue.

Inaki-LL added a comment.EditedFeb 22 2018, 9:07 AM

@Deskana Please take a look at my History in my Basque WP Sandbox (internal link did not work out...). You will see in the diffs numbered 1 to 8 different tests I have done. Usually the first edits are fine, but the editing becomes increasingly erratic.

Except for test 5, the link should fit a full word or phrase.

@Inaki-LL I'm really sorry, and I genuinely don't mean to be rude, but again I need to repeat my last two requests: please provide me with specific reproduction steps to show me how to recreate the issue. Showing me more diffs isn't going to help me reproduce or understand this problem. If you don't do that then I'm not going to be able to help you because I still don't understand what problem it is that you're reporting.

@Deskana Yes, I am also sorry. The thing is I do not know how to reproduce other than provide diffs, since I am only now coming to grips with Phabricator, but still do not know what you mean with reproduce or where I can do that... sorry also for my sort of primitive Phabricator knowledge.

As far as my understanding goes, the best way to reproduce the issue is to go the link provided above, write down a short text in the Sandbox, and keep adding links and references 4 or 5 times in the Visual Editor (same interface as in English), and see what happens.

I will do my best reading the technical (debug...) and posting guidelines, but that will take more time for me. Thank you

@Inaki-LL Mozilla have a nice guide on the best way to report bug. Basically, provide a step by step guide of exactly what you did to cause the bug to happen. You've kind of provided that in your last message, so I'll check those steps out when I get the chance.

Thanks for the link Deskana, will read it.

Inaki-LL added a comment.EditedMar 6 2018, 2:18 PM

@Deskana I will reproduce the steps I take,

  1. First, go to the article Ida_Kamińska in Basque
  2. Open to edit by means of "Aldatu" (Visual Editor)
  3. Select the word "Varsovia".
  4. Click on the Menu "Lotura" (Ctrl+K)
  5. Press blue botton, "Egina"

See the link shifted out of the selection

  1. Put the cursor on the right hand side of the phrase "haien omenez."
  2. Click on the menu "Aipatu" (Ctrl+Shift+K)

See the point of insertion has shifted to the left into the middle of the word "omenez", splitting it in two

I hope this helps fix the issue. Regards

Theklan added a comment.EditedMar 7 2018, 10:14 AM

I have noted a similar problem with the New Wikitext Editor but working in source. The text goes wild, and the cursor does not write in the actual place, making it sometimes virtually impossible to write something without saving and starting again.

@Inaki-LL Thanks for the steps! I can reproduce the problem now. In fact, it seems to be even worse, as when I tried to find "Varsovia" using the search function, it highlighted something completely different. However, I can't reproduce the problem on other random pages that I tried, such as 1957ko Kontxako Bandera, Millbank (Antrim konderria), and Lavaurette.

I figured out what the problem is. There's some <nowiki/> tags in the article. Sometimes these tags are inserted incorrectly by the visual editor, but quite frequently their insertion is correct to represent what the user actually wrote. To use an example from the article you linked, you have the word antzerkian but you only want antzerki to be linked. If you use the wikitext [[antzerki]]an then the whole word will be linked, which isn't what you wanted. If you use [[antzerki]]<nowiki/>an, then it does exactly what you want: antzerki is linked, and an is not. The visual editor uses this syntax when a user links only part of a word.

The above is all fine, but there is a bug right now where <nowiki/> tags can cause text to get mangled; this bug is T189118, and it seems to be what's causing the problem you're experiencing. Since this bug appears to be very closely related to that one, I'm going to merge them together.

Theklan reopened this task as Open.Mar 12 2018, 12:33 PM

I think that there are more than one problem here: with visual editor but New wikitext mode something like this is also happening, but without the <nowiki /> tags. You can try to reproduce it, if you want, but it seem quite random. Mainly when I copy something with a link from another place it breaks lines, changes the cursor position... now I'm using the old wikitext mode in the code editor, because it was impossible to continue using it.

Deskana closed this task as Invalid.Mar 12 2018, 1:25 PM

I think that there are more than one problem here: with visual editor but New wikitext mode something like this is also happening, but without the <nowiki /> tags. You can try to reproduce it, if you want, but it seem quite random. Mainly when I copy something with a link from another place it breaks lines, changes the cursor position... now I'm using the old wikitext mode in the code editor, because it was impossible to continue using it.

This sounds like T188839. Does that seem to be the same as your issue?

It's not helpful to have a single generic task which contains multiple unrelated, or very loosely related, bug reports. This task was specifically about a text highlight bug in the visual editor, so if there's a bug you're experiencing then please file it separately. Thanks!