Page MenuHomePhabricator

Enable membership login in Zynatic
Closed, ResolvedPublic3 Estimated Story Points

Description

  • Order the membership-login component from Zynatic
  • Test run with non-admin login to identify any pain points
  • Fix any stumble blocks/pain points

Event Timeline

Component ordered and activated.

First test-login by @AxelPettersson_WMSE :

  • After login, redirected to wikimedia.se
    • Likely caused by trying to access a page for which the user has no permission.
    • Fixed by setting KonfigMedlemsregistetReturadress (URL) to <loginurl>/Medlemssidan
  • There was no prompt for renewing membership
    • Going to the pay fee link shows the 2018 membership as unpaid
    • When all due are paid the same page looks weird.
  • Not all membership details are viewable/editable
    • Kön is viewable but not editable
    • Smeknamn is neither viewable nor editable
  • View/update information refer to "familj" despite the account types being set to individual

Contacted Zynatic about these.

We got an e-mail about updated membership details on 2018-02-19, to info@wikimedia.se from info@wikimedia.se (Ticket#2018021910005548). We might want to turn of this type of e-mails notification, to limit the number of places where personal data is handled.

  • After login, redirected to wikimedia.se
    • Likely caused by trying to access a page for which the user has no permission.
    • Fixed by setting KonfigMedlemsregistetReturadress (URL) to <loginurl>/Medlemssidan

Correct solution

  • There was no prompt for renewing membership

Fixed

  • When all due are paid the same page looks weird.

Zynatic are working on this

  • Not all membership details are viewable/editable
    • Kön is viewable but not editable

Now editable

  • Smeknamn is neither viewable nor editable

Zynatic are working on this T185469: Requested Zynatic development

  • View/update information refer to "familj" despite the account types being set to individual

Zynatic are working on this

We got an e-mail about updated membership details on 2018-02-19, to info@wikimedia.se from info@wikimedia.se (Ticket#2018021910005548). We might want to turn of this type of e-mails notification, to limit the number of places where personal data is handled.

This was confirmed by a second change.
Zynatic have been informed

Lokal_Profil updated the task description. (Show Details)Feb 23 2018, 9:30 AM
Lokal_Profil added a comment.EditedFeb 26 2018, 3:47 PM

Possibly we can use medlem[at]wikimedia.se for this one instead @Jopparn @Evelina-Bang-WMSE what do you guys think (as the recipients of these emails).

Or should medlem@ rather redirect to info@ ?

Lokal_Profil closed this task as Resolved.Feb 26 2018, 4:08 PM
Lokal_Profil reopened this task as Open.
Lokal_Profil claimed this task.
Lokal_Profil updated the task description. (Show Details)
Lokal_Profil set the point value for this task to 3.

Resolved other than the open question about which e-mail should get the notifications.

Resolved other than the open question about which e-mail should get the notifications.

I vote info@

Lokal_Profil closed this task as Resolved.Mar 7 2018, 9:05 AM
Lokal_Profil moved this task from 📆 This week to ☑️ Done on the User-LokalProfil board.

Resolved other than the open question about which e-mail should get the notifications.

I vote info@

OK. I'll leave the address as info@ (even though this means the e-mail will be sent from info@ to info@.

Note that Zynatic has now updated the system so that no personal information is included in the e-mails. The e-mails can be deactivated BUT this then means that we will not get any e-mails from people wishing to become members (through the system).