Create fallback for MediaWiki:Licenses
Closed, ResolvedPublic

Description

If no license is set via MediaWiki:Licenses then the license selector remains blank and files can't be uploaded, for example: https://commons.wikimedia.org/w/index.php?title=Special:Upload&uselang=bar (No licenses set in MediaWiki:Licenses/bar, fallback to MediaWiki:Licenses missing). Can we have a fallback please?

Is this regression or related to T68550?

Restricted Application added a project: Multimedia. · View Herald TranscriptMar 3 2018, 1:34 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

Well, the timing of this ticket & the recent changes to the license dropdown code is suspicious, but I don't think it's a regression.
The code that pulls the info from the message has not changes, and when I checked out the old code on my local machine, it worked just the same before.

But it's not too hard to fall back to English when no licenses are available in a given language. Patch coming up.

Change 416728 had a related patch set uploaded (by Matthias Mullie; owner: Matthias Mullie):
[mediawiki/core@master] Fall back to default language when no i18n'ed licenses available

https://gerrit.wikimedia.org/r/416728

Change 416729 had a related patch set uploaded (by Matthias Mullie; owner: Matthias Mullie):
[mediawiki/extensions/3D@master] Fall back to default language when no i18n'ed licenses available

https://gerrit.wikimedia.org/r/416729

Tgr added a comment.Mar 6 2018, 9:24 PM

Messages always fall back to English when there is no content in the interface language. The problem is that fallbacks don't use the database. That is an old bug, see T3495: Improve message source fallback flow. But the Licenses class already forces the content language, and on Commons that's English which has no fallback, so in theory it shouldn't be affected.

Ramsey-WMF moved this task from Untriaged to Triaged on the Multimedia board.Mar 9 2018, 6:33 PM
Ramsey-WMF triaged this task as Normal priority.

Change 416729 merged by jenkins-bot:
[mediawiki/extensions/3D@master] Fall back to default language when no i18n'ed licenses available

https://gerrit.wikimedia.org/r/416729

Change 416728 merged by jenkins-bot:
[mediawiki/core@master] Fall back to default language when no i18n'ed licenses available

https://gerrit.wikimedia.org/r/416728

matthiasmullie closed this task as Resolved.May 29 2018, 12:14 PM