Page MenuHomePhabricator

AbuseFilter isn't blocking
Closed, ResolvedPublic

Description

With wmf.25, AbuseFilter blocks stopped working. For example, see AbuseLog on it.wiki. This is surely related to https://gerrit.wikimedia.org/r/#/c/412892/. I noticed that the new blocks (ones with custom duration) do work, while the old ones don't. It's surely due to some backward compatibility bug which however I won't be able to investigate before tomorrow.

Event Timeline

Daimona created this task.Mar 15 2018, 10:28 PM
Restricted Application added subscribers: Scoopfinder, Aklapper. · View Herald TranscriptMar 15 2018, 10:28 PM
Daimona triaged this task as Unbreak Now! priority.Mar 15 2018, 10:29 PM
Daimona moved this task from Backlog to Internal bugs on the AbuseFilter board.
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptMar 15 2018, 10:29 PM

A bit more of information for anyone who wants to take a look: likely the bug happens in AbuseFilter.class.php at lines 881-916 (referred to the custom block patch diff).

Trouble probably found: those lines miss a declaration for global variables wgAbuseFilterBlockDuration and wgAbuseFilterAnonBlockDuration. I'd be relieved if someone may test and merge it if necessary. I'm sorry but right now I'm writing from mobile and have no way to do it.

Possibly related T189829

@Paladox I'd say my assumption above is correct. Global declarations missing make blocks with old variables fail. Adding them should solve the problem. That task is too old to be the cause

@Daimona yep, this is being discussed in #wikimedia-operations :)

Change 419944 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/AbuseFilter@master] Add missing global statements

https://gerrit.wikimedia.org/r/419944

Change 419945 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/extensions/AbuseFilter@wmf/1.31.0-wmf.25] Add missing global statements

https://gerrit.wikimedia.org/r/419945

Daimona added a subscriber: Reedy.Mar 15 2018, 10:51 PM

@Reedy a huge thank you for merging. Since you're here, may I ask you to please backport https://gerrit.wikimedia.org/r/#/c/419480/ too? Many thanks again.

Change 419945 merged by Reedy:
[mediawiki/extensions/AbuseFilter@wmf/1.31.0-wmf.25] Add missing global statements

https://gerrit.wikimedia.org/r/419945

Possibly related T189829

It's not. Still broken

Change 419944 merged by jenkins-bot:
[mediawiki/extensions/AbuseFilter@master] Add missing global statements

https://gerrit.wikimedia.org/r/419944

Daimona closed this task as Resolved.Mar 15 2018, 11:09 PM
Daimona assigned this task to Reedy.