Page MenuHomePhabricator

[cx2-testing] Math formulas not displayed
Closed, ResolvedPublic

Description

  1. On cx2-testing, start a New translation of an article that has some math formulas, e.g. 'Snub cube'
  2. The formulas are not displayed and cannot be translated.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 16 2018, 9:25 AM
Pginer-WMF triaged this task as Normal priority.Mar 19 2018, 7:49 AM
Pginer-WMF moved this task from Needs Triage to CX2 on the ContentTranslation board.

Change 424565 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] CX2: Customized Extension node

https://gerrit.wikimedia.org/r/424565

Change 424983 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/extensions/ContentTranslation@master] ve.init.mw.CXTarget: Customize parsefragment

https://gerrit.wikimedia.org/r/424983

Change 424565 abandoned by Santhosh:
CX2: Customized Extension node

Reason:
Abandoning in favor of https://gerrit.wikimedia.org/r/c/424983/

https://gerrit.wikimedia.org/r/424565

Change 424983 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] ve.init.mw.CXTarget: Customize parsefragment

https://gerrit.wikimedia.org/r/424983

Arrbee moved this task from Backlog to QA on the Language-2018-Apr-June board.
santhosh claimed this task.Apr 11 2018, 9:46 AM
Etonkovidova closed this task as Resolved.Apr 13 2018, 8:53 PM

Checked in cx2-testing - looks great:

Did this solved T137803 at least for CX2?

Did this solved T137803 at least for CX2?

@Pginer - I re-checked T137803: ContentTranslation deletes <math> formulas from article in cx2-testing - the issue is still present. This phab task was about not displaying math formulas when translating an article. T137803 is about displaying Math formulas correctly after publishing a translated article. Presently, the formulas will be displayed as following and will need manual correction:

<math> \langle f,g\rangle = \int \overline{f(x)}g(x)\,dx .</math>

I gave a try and got a similar issue:

@KartikMistry or @santhosh may confirm whether this may be some issue of the testing server math support or whether the issue is also happening in production. If the problem is confirmed it would be good to have a ticket for CX2 to get it solved.

We probably need, Extension:Math in testing server. Adding it.

I've install Extension:Math in cx2-testing now. @Etonkovidova Can you please recheck? Quick test seems working for in Snub cube article.