Page MenuHomePhabricator

Update API to access short descriptions in Content Translation
Closed, ResolvedPublic

Description

Content Translation shows short descriptions of pages at different points (including when searching for an article to translate, when showing suggestions or when showing information about links). these descriptions were obtained directly from Wikidata. Now that Wikidata descriptions can be overridden (T184000), a different API needs to be used to make sure local descriptions are used when available.

Details

Related Gerrit Patches:
mediawiki/services/cxserver : masterUpdate API to access short descriptions
mediawiki/extensions/ContentTranslation : masterUpdate description API

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 3 2018, 10:51 AM
Pginer-WMF triaged this task as Medium priority.Apr 3 2018, 10:51 AM
Pginer-WMF renamed this task from Update API to access short descriptions to Update API to access short descriptions in Content Translation.Apr 3 2018, 10:53 AM
LGoto added a subscriber: LGoto.May 1 2018, 7:43 PM

Hi @Pginer-WMF just checking on this. Do you have some estimate of when it might be done? Thanks!

Hi @Pginer-WMF just checking on this. Do you have some estimate of when it might be done? Thanks!

I'd expect this to be completed by the end of May.

Change 430371 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Update description API

https://gerrit.wikimedia.org/r/430371

Change 430371 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Update description API

https://gerrit.wikimedia.org/r/430371

@Etonkovidova when this is checked you will need to make sure descriptions are shown where they need to be and that there are no regressions.
Also, find some page that has different description than one coming from Wikidata and check which is shown. One example is this article, which has different description defined in wikitext (at the time of writing this).

Change 430573 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/services/cxserver@master] Update API to access short descriptions

https://gerrit.wikimedia.org/r/430573

Etonkovidova closed this task as Resolved.May 5 2018, 12:55 AM

I checked with the 'Wagon train" and "The Big Sleep" ( articles for whether the descriptions in Wikidata and descriptions in CX are matching. These articles and other cases showed no discrepancies and no regression.

Wagon train shows the description according to {{short description|Western television series aired 1957-1965}} not the description from wikidata: https://www.wikidata.org/wiki/Q772909: television program

The Big Sleep has {{DEFAULTSORT:Big Sleep, The (1946 Film)}} which is not valid anymore, so the wikidata description is used.

Petar.petkovic reopened this task as Open.May 5 2018, 1:02 AM

Reopening, because 430573 is still in review. Thank you, @Etonkovidova, for checking 430371.

Change 430573 merged by jenkins-bot:
[mediawiki/services/cxserver@master] Update API to access short descriptions

https://gerrit.wikimedia.org/r/430573

Etonkovidova closed this task as Resolved.May 14 2018, 11:21 PM

Re-checked - works as expected.

Mentioned in SAL (#wikimedia-operations) [2018-05-16T04:39:50Z] <kartik@tin> Started deploy [cxserver/deploy@7e898c7]: Update cxserver to 112a1a1 (T191285)

Mentioned in SAL (#wikimedia-operations) [2018-05-16T04:43:42Z] <kartik@tin> Finished deploy [cxserver/deploy@7e898c7]: Update cxserver to 112a1a1 (T191285) (duration: 03m 52s)