Page MenuHomePhabricator

Error occurs in file page for Own uploaded files@1.31.0-wmf.30 (e8360e8)
Closed, ResolvedPublic

Description

Steps to Reproduce:

  1. Go to https://test.wikipedia.org/wiki/Special:Upload with Chrome 66.0.3359.117(Official Build) (64 bit)
  2. Select "Source filename:"
  3. choose file from local
  4. choose any licenses
  5. push "Upload file" button
  6. Error occurs in file page for Own uploaded files

Error messages: P7018

does not occurs error in alternative account or non-logged

  • edited: this bug occurs at mediawiki.org too

Event Timeline

Rxy created this task.Apr 19 2018, 6:45 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 19 2018, 6:45 PM
thcipriani triaged this task as Unbreak Now! priority.Apr 19 2018, 6:50 PM
thcipriani added subscribers: aaron, thcipriani.

Adding as train blocker for 1.31.0-wmf.30, setting as UBN!

Adding in @aaron since I saw a few commits to LoadBalancer in https://www.mediawiki.org/wiki/MediaWiki_1.31/wmf.30/Changelog

Backtrace is:

1[WtjhXQpAAEAAAAIbHncAAAAG] /wiki/File:Rxy.svg.png InvalidArgumentException from line 875 of /srv/mediawiki/php-1.31.0-wmf.30/includes/libs/rdbms/loadbalancer/LoadBalancer.php: No server with index 'Array'.
2
3Backtrace:
4
5#0 /srv/mediawiki/php-1.31.0-wmf.30/includes/libs/rdbms/loadbalancer/LoadBalancer.php(746): Wikimedia\Rdbms\LoadBalancer->openConnection(array, boolean, integer)
6#1 /srv/mediawiki/php-1.31.0-wmf.30/includes/GlobalFunctions.php(2869): Wikimedia\Rdbms\LoadBalancer->getConnection(array, array, boolean)
7#2 /srv/mediawiki/php-1.31.0-wmf.30/includes/changes/RecentChange.php(199): wfGetDB(array)
8#3 /srv/mediawiki/php-1.31.0-wmf.30/includes/page/Article.php(1061): RecentChange::newFromConds(array, string, array)
9#4 /srv/mediawiki/php-1.31.0-wmf.30/includes/page/Article.php(953): Article->showPatrolFooter()
10#5 /srv/mediawiki/php-1.31.0-wmf.30/includes/page/Article.php(662): Article->showViewFooter()
11#6 /srv/mediawiki/php-1.31.0-wmf.30/includes/page/ImagePage.php(150): Article->view()
12#7 /srv/mediawiki/php-1.31.0-wmf.30/includes/actions/ViewAction.php(68): ImagePage->view()
13#8 /srv/mediawiki/php-1.31.0-wmf.30/includes/MediaWiki.php(500): ViewAction->show()
14#9 /srv/mediawiki/php-1.31.0-wmf.30/includes/MediaWiki.php(294): MediaWiki->performAction(ImagePage, Title)
15#10 /srv/mediawiki/php-1.31.0-wmf.30/includes/MediaWiki.php(861): MediaWiki->performRequest()
16#11 /srv/mediawiki/php-1.31.0-wmf.30/includes/MediaWiki.php(524): MediaWiki->main()
17#12 /srv/mediawiki/php-1.31.0-wmf.30/index.php(42): MediaWiki->run()
18#13 /srv/mediawiki/w/index.php(3): include(string)
19#14 {main}

Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptApr 19 2018, 6:50 PM
Reedy added a subscriber: Reedy.Apr 19 2018, 7:00 PM

From Article.php...

				$rc = RecentChange::newFromConds(
					[
						'rc_type' => RC_LOG,
						'rc_log_type' => 'upload',
						'rc_timestamp' => $newestUploadTimestamp,
						'rc_namespace' => NS_FILE,
						'rc_cur_id' => $title->getArticleID()
					],
					__METHOD__,
					[ 'USE INDEX' => 'rc_timestamp' ]
				);

The USE INDEX is the problem here

public static function newFromConds(
        $conds,
        $fname = __METHOD__,
        $dbType = DB_REPLICA
) {

https://github.com/wikimedia/mediawiki/blame/master/includes/page/Article.php#L1069

But the code doesn't seem to have been changed recently on either side...

Rxy renamed this task from Error occurs in file page for Own uploaded files@test.wikipedia to Error occurs in file page for Own uploaded files@1.31.0-wmf.30 (e8360e8).Apr 19 2018, 7:02 PM
Rxy updated the task description. (Show Details)

Change 427754 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/core@wmf/1.31.0-wmf.29] Don't pass USE INDEX to a $dbType parameter

https://gerrit.wikimedia.org/r/427754

Change 427755 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/core@wmf/1.31.0-wmf.30] Don't pass USE INDEX to a $dbType parameter

https://gerrit.wikimedia.org/r/427755

Change 427756 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/core@REL1_31] Don't pass USE INDEX to a $dbType parameter

https://gerrit.wikimedia.org/r/427756

Change 427757 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/core@REL1_30] Don't pass USE INDEX to a $dbType parameter

https://gerrit.wikimedia.org/r/427757

Change 427758 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/core@REL1_27] Don't pass USE INDEX to a $dbType parameter

https://gerrit.wikimedia.org/r/427758

Change 427759 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/core@REL1_28] Don't pass USE INDEX to a $dbType parameter

https://gerrit.wikimedia.org/r/427759

Change 427760 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/core@REL1_29] Don't pass USE INDEX to a $dbType parameter

https://gerrit.wikimedia.org/r/427760

Change 427755 merged by jenkins-bot:
[mediawiki/core@wmf/1.31.0-wmf.30] Don't pass USE INDEX to a $dbType parameter

https://gerrit.wikimedia.org/r/427755

Mentioned in SAL (#wikimedia-operations) [2018-04-19T19:35:47Z] <thcipriani@tin> Synchronized php-1.31.0-wmf.30/includes/page/Article.php: [[gerrit:427755|Do not pass USE INDEX to a $dbType parameter]] T192584 (duration: 01m 17s)

Change 427759 abandoned by Reedy:
Don't pass USE INDEX to a $dbType parameter

https://gerrit.wikimedia.org/r/427759

aaron added a comment.Apr 19 2018, 7:51 PM

I assume daf0514345f03 exposed this bug.

Change 427754 abandoned by Reedy:
Don't pass USE INDEX to a $dbType parameter

https://gerrit.wikimedia.org/r/427754

But the code doesn't seem to have been changed recently on either side...

It did, rMWdaf0514345f0: rdbms: make $i in LoadBalancer::getConnection override $groups

Change 427756 merged by jenkins-bot:
[mediawiki/core@REL1_31] Don't pass USE INDEX to a $dbType parameter

https://gerrit.wikimedia.org/r/427756

thcipriani lowered the priority of this task from Unbreak Now! to Normal.Apr 19 2018, 10:20 PM

Lowering priority since I removed as a train blocker (thanks @Reedy!)

Change 427751 merged by jenkins-bot:
[mediawiki/core@master] Don't pass USE INDEX to a $dbType parameter

https://gerrit.wikimedia.org/r/427751

Change 427758 merged by jenkins-bot:
[mediawiki/core@REL1_27] Don't pass USE INDEX to a $dbType parameter

https://gerrit.wikimedia.org/r/427758

Change 427760 merged by jenkins-bot:
[mediawiki/core@REL1_29] Don't pass USE INDEX to a $dbType parameter

https://gerrit.wikimedia.org/r/427760

Change 427757 merged by jenkins-bot:
[mediawiki/core@REL1_30] Don't pass USE INDEX to a $dbType parameter

https://gerrit.wikimedia.org/r/427757

Krinkle closed this task as Resolved.EditedMay 3 2018, 12:57 AM
Krinkle claimed this task.
Krinkle edited projects, added Wikimedia-Rdbms; removed Patch-For-Review.

Change 427755 had a related patch set uploaded (by Reedy; owner: Reedy):
[mediawiki/core@wmf/1.31.0-wmf.30] Don't pass USE INDEX to a $dbType parameter
https://gerrit.wikimedia.org/r/427755

The backport of this patch from master to 1.31.0-wmf.30 on April 19th fixed the issue.

Closing.