Page MenuHomePhabricator

Special:EditWatchlist TOC navigation doesn't work since OOUI conversion: <legend> elements have no "id" parameters
Closed, ResolvedPublic

Description

Chrome Version 66.0.3359.139 (Official Build) (64-bit)
MacOS High Sierra version 10.13.4 (17E202)
Vector skin

When I navigate to https://en.wikipedia.org/wiki/Special:EditWatchlist, I get what looks like a correct TOC

, but the links don't work. The anchor tags are generated in the TOC, but the matching anchors (#editwatchlist-ns0, etc) don't exist on the page.

TOC HTML:

<div id="toc" class="toc"><div class="toctitle" lang="en" dir="ltr"><h2>Contents</h2><span class="toctoggle">&nbsp;[<a role="button" tabindex="0" class="togglelink">hide</a>]&nbsp;</span></div>

<ul>
<li class="toclevel-1"><a href="#editwatchlist-ns0"><span class="tocnumber">1</span> <span class="toctext">(Article)</span></a></li>

<li class="toclevel-1"><a href="#editwatchlist-ns2"><span class="tocnumber">2</span> <span class="toctext">User</span></a></li>

<li class="toclevel-1"><a href="#editwatchlist-ns4"><span class="tocnumber">3</span> <span class="toctext">Wikipedia</span></a></li>

<li class="toclevel-1"><a href="#editwatchlist-ns10"><span class="tocnumber">4</span> <span class="toctext">Template</span></a></li>

<li class="toclevel-1"><a href="#editwatchlist-ns118"><span class="tocnumber">5</span> <span class="toctext">Draft</span></a></li>
</ul>
</div>

Header HTML (no id anywhere):

<legend class="oo-ui-fieldsetLayout-header">
  <span class="oo-ui-iconElement-icon"></span>
  <span class="oo-ui-labelElement-label">(Main)</span>
</legend>

Details

Related Gerrit Patches:

Event Timeline

RoySmith created this task.May 11 2018, 1:33 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 11 2018, 1:33 PM
Aklapper renamed this task from Special:EditWatchlist TOC navigation doesn't work to Special:EditWatchlist TOC navigation doesn't work since OOUI conversion.May 12 2018, 3:14 PM

Confirmed on both Wikidata and the Dutch Wikipedia using Firefox.

Aklapper renamed this task from Special:EditWatchlist TOC navigation doesn't work since OOUI conversion to Special:EditWatchlist TOC navigation doesn't work since OOUI conversion: <legend> elements have no "id" parameters.May 30 2018, 12:33 PM
Aklapper triaged this task as High priority.
Aklapper added a subscriber: D3r1ck01.

Change 437142 had a related patch set uploaded (by JJMC89; owner: JJMC89):
[mediawiki/core@master] Revert "Use OOUI form for edit watchlist"

https://gerrit.wikimedia.org/r/437142

Change 437142 abandoned by Esanders:
Revert "Use OOUI form for edit watchlist"

https://gerrit.wikimedia.org/r/437142

Change 437290 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/core@master] Restore section IDs on Special:EditWatchlist

https://gerrit.wikimedia.org/r/437290

@JJMC89 Thanks for tracking down the buggy commit! It seems that no one involved in the original change watches the MediaWiki-Watchlist project, so we missed this bug report initially :(

Change 437290 merged by jenkins-bot:
[mediawiki/core@master] Restore section IDs on Special:EditWatchlist

https://gerrit.wikimedia.org/r/437290

matmarex closed this task as Resolved.Jun 4 2018, 6:27 PM
matmarex assigned this task to Esanders.
matmarex removed a project: Patch-For-Review.

The fix will be deployed to Wikimedia wikis this week, 5-7 June, per the usual schedule. You should be able to test it on https://en.wikipedia.beta.wmflabs.org in a few minutes.

Vvjjkkii renamed this task from Special:EditWatchlist TOC navigation doesn't work since OOUI conversion: <legend> elements have no "id" parameters to g4caaaaaaa.Jul 1 2018, 1:10 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Esanders as the assignee of this task.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: gerritbot, Aklapper.
CommunityTechBot renamed this task from g4caaaaaaa to Special:EditWatchlist TOC navigation doesn't work since OOUI conversion: <legend> elements have no "id" parameters.Jul 2 2018, 3:14 PM
CommunityTechBot closed this task as Resolved.
CommunityTechBot assigned this task to Esanders.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added subscribers: gerritbot, Aklapper.