Page MenuHomePhabricator

CX2: Focus on the empty paragraph after "no MT" option is selected
Closed, ResolvedPublic

Description

The Automatic Translation card (T188247) allows to select between MT services. The "don't use machine translation" option allows users to start their translation from scratch.

Currently selecting this option makes the target paragraph to go away completely, which results in the input focus to be lost. The expected result would be to have an empty paragraph with the input focus where the user can type in without further interactions.

Event Timeline

Pginer-WMF triaged this task as Normal priority.May 31 2018, 9:46 AM
Pginer-WMF created this task.

Change 441033 had a related patch set uploaded (by Nikerabbit; owner: Nikerabbit):
[mediawiki/extensions/ContentTranslation@master] CX2: Focus on the empty paragraph after "no MT" option is selected

https://gerrit.wikimedia.org/r/441033

Nikerabbit moved this task from Priority backlog to In Review on the Language-2018-Apr-June board.

Change 441033 merged by Petar.petkovic:
[mediawiki/extensions/ContentTranslation@master] CX2: Focus on the empty paragraph after "no MT" option is selected

https://gerrit.wikimedia.org/r/441033

Etonkovidova closed this task as Resolved.Jun 28 2018, 12:56 AM
Etonkovidova added a subscriber: Etonkovidova.

The issue is still present when the switch to "Don't use machine translation" happens in the first paragraph - files as T198368: CX2: " Uncaught TypeError: Cannot read property 'getModel" displayed when "Don't use machine translation" option used for the first paragraph.

Arrbee moved this task from QA to Done on the Language-2018-Apr-June board.Jun 28 2018, 8:11 AM
Vvjjkkii renamed this task from CX2: Focus on the empty paragraph after "no MT" option is selected to bxbaaaaaaa.Jul 1 2018, 1:06 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii removed Nikerabbit as the assignee of this task.
Vvjjkkii raised the priority of this task from Normal to High.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed subscribers: gerritbot, Aklapper.
CommunityTechBot renamed this task from bxbaaaaaaa to CX2: Focus on the empty paragraph after "no MT" option is selected.Jul 2 2018, 2:08 AM
CommunityTechBot closed this task as Resolved.
CommunityTechBot assigned this task to Nikerabbit.
CommunityTechBot lowered the priority of this task from High to Normal.
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot added subscribers: gerritbot, Aklapper.