Cannot access user contributions of user without user page on mobile
Closed, ResolvedPublic1 Story Points

Description

In the mobile diff, a click on the user name usually leads to their mobile user page, where one finds a link to their contributions. For users without a user page (aka red link), however, the mobile website launches into the editor instead of displaying the user page. Going back a step in the browser returns to the diff.

As far as I can see, for these user accounts there is no way to reach the user contributions by clicking a link. Instead, one has to manually go to the Special:Contributions URL.

Replication instructions

Actual: User cannot navigate to contributions

Acceptance criteria

  • The user on a diff page should link to the user page in view mode NOT edit mode

e.g. https://en.m.wikipedia.beta.wmflabs.org/w/index.php?title=User:Mr_Selenium

QA steps

Follow the replication steps. The editor should not load when the username is clicked on.
IT may help to compare this behaviour to https://en.m.wikipedia.org/wiki/Special:MobileDiff/349080 to understand how this worked before.

Cirdan created this task.Jun 18 2018, 10:13 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 18 2018, 10:13 AM
Jdlrobson updated the task description. (Show Details)Jun 18 2018, 11:41 PM
Jdlrobson added a project: Readers-Web-Backlog.
Jdlrobson added a subscriber: Jdlrobson.

Nope. That's a new one! Thanks for the report!

ovasileva triaged this task as Normal priority.Jun 19 2018, 3:10 PM

Change 441145 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@master] Username on mobile diff should never point to editor

https://gerrit.wikimedia.org/r/441145

Jdlrobson updated the task description. (Show Details)Jun 19 2018, 11:36 PM
Jdlrobson updated the task description. (Show Details)

Change 441145 merged by Jdlrobson:
[mediawiki/extensions/MobileFrontend@master] Username on mobile diff should never point to editor

https://gerrit.wikimedia.org/r/441145

Jdlrobson updated the task description. (Show Details)
Jdlrobson assigned this task to alexhollender.
Jdlrobson lowered the priority of this task from Normal to Low.

A patch got merged to fix this. Please take a look when you have time to confirm that this behaviour is the correct behaviour

this is working as intended, moving to QA

ovasileva set the point value for this task to 1.Jun 27 2018, 5:10 PM

Looks good to me on Beta
https://en.m.wikipedia.beta.wmflabs.org/wiki/Special:MobileDiff/349080
Clicking on contributions now goes to the expected location




ovasileva closed this task as Resolved.Jun 28 2018, 10:31 AM
ovasileva added a subscriber: ovasileva.

looks good

Johan added a subscriber: Johan.Jun 28 2018, 2:00 PM

When will this go into production? Week after next (no new MediaWiki version next week)?

merged on Tue 26 so will be cut in the branch next tuesday (3rd July), so this should go into 1.32.0-wmf.12.
Looks like 1.32.0-wmf.12 is scheduled for July 10th if things go to plan. There are no deploys next week, but bear in mind this weeks train was rolled back so may take a little longer.

Vvjjkkii renamed this task from Cannot access user contributions of user without user page on mobile to yqaaaaaaaa.Jul 1 2018, 1:03 AM
Vvjjkkii reopened this task as Open.
Vvjjkkii raised the priority of this task from Low to High.
Vvjjkkii removed ABorbaWMF as the assignee of this task.
Vvjjkkii updated the task description. (Show Details)
Vvjjkkii removed the point value for this task.
Vvjjkkii edited subscribers, added: ABorbaWMF; removed: gerritbot, Aklapper.
CommunityTechBot set the point value for this task to 1.Jul 2 2018, 5:00 AM
CommunityTechBot updated the task description. (Show Details)
CommunityTechBot assigned this task to ABorbaWMF.
CommunityTechBot lowered the priority of this task from High to Low.
CommunityTechBot closed this task as Resolved.
CommunityTechBot renamed this task from yqaaaaaaaa to Cannot access user contributions of user without user page on mobile.
CommunityTechBot edited subscribers, added: gerritbot, Aklapper; removed: ABorbaWMF.