Page MenuHomePhabricator

CX2: Allow marking warnings as resolved
Closed, ResolvedPublic

Description

Warnings tell the user about circumstances to consider, such as the risk of overwriting an existing article. If the user is already aware of the situation and makes a decision (e.g., overwrite the existing content) it does not make sense to continue showing the warning forever since it can distract from other more relevant warnings.

In order for users to discard warnings we want to provide a "Mark as resolved" action to most of the warnings (at least those where we cannot provide a quick action to fix them).

This was part of the general spec for issues (T189488) and specific cases such as T190038, but currently not supported (illustrated below) since it requires additional effort to store the status for the marked warnings.

Event Timeline

Pginer-WMF triaged this task as Normal priority.Jun 26 2018, 10:43 AM
Pginer-WMF created this task.
Arrbee moved this task from Needs Triage to CX2 on the ContentTranslation board.Jun 26 2018, 5:54 PM

Change 452416 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Add "Mark as resolved" option for translation issues

https://gerrit.wikimedia.org/r/452416

Change 452416 merged by Petar.petkovic:
[mediawiki/extensions/ContentTranslation@master] Add "Mark as resolved" option for translation issues

https://gerrit.wikimedia.org/r/452416

Petar.petkovic moved this task from In Review to QA on the Language-2018-July-September board.

Marking issues as resolved works across one session.
Persistence of resolved state isn't yet implemented, so going back to the dashboard and opening the draft does not remember particular issue as resolved.

Etonkovidova closed this task as Resolved.Aug 21 2018, 11:28 PM
Etonkovidova added a subscriber: Etonkovidova.

Checked in cx2:

@Petar.petkovic

Persistence of resolved state isn't yet implemented, so going back to the dashboard and opening the draft does not remember particular issue as resolved.

Is it captured in some ticket(s)? It looks to me as a big issue.

Also, I saw the issue that @Pginer mentioned before - the mismatch between paragraph indicators and the issue summary cards. I filed it as a separate tickets - T202468: CX2: The issue summary card not updated promptly If it's been reported already, please close my ticket as duplicate. The issue looks like a regression to me - I checked it before and the issue summary card was totally in sync with paragraphs marking.

Petar.petkovic moved this task from QA to Done on the Language-2018-July-September board.

@Petar.petkovic

Persistence of resolved state isn't yet implemented, so going back to the dashboard and opening the draft does not remember particular issue as resolved.

Is it captured in some ticket(s)? It looks to me as a big issue.

I have created T202544: CX2: Make "mark as resolved" feature work across sessions.