Page MenuHomePhabricator

Islands and other map features hidden by bays
Closed, ResolvedPublic

Description

In the OpenStreetMap maps imported to Wikimedia, bays can hide islands within them. An example of this is an island Gressholmen just outside Oslo, Norway. The island itself is not visible on the map, but zoomed sufficiently paths and houses on the island can be seen underneath the water. Links to maps below.

I asked about this on the Norwegian mailing list for OpenStreetMap, and learned first that this was probably because there was modelled a bay there. Later that this apparently is a common cause and that it is common that users of OpenStreetMap gets this wrong. However I was told that the community around osm2pgsql have a way to deal with it. The fact that this island is clearly shown on OpenStreetMap.org testifies to that.

There are other cases I managed relatively easily to find, eg. close to Stockholm.
I don't know if Tag:natural=bay is a unique case.

Example Gressholmen (Wikidata Q952279):

Wikimedia:

https://maps.wikimedia.org/?lang=nb#16/59.8837/10.7188

OpenStreetMap.org:

https://www.openstreetmap.org/?mlat=59.8824&mlon=10.7173&zoom=15#map=15/59.8824/10.7173

OpenStreetMap.org item for the island:

https://www.openstreetmap.org/way/4154441#map=16/59.8825/10.7187

OpenStreetMap.org item for the bay:

https://www.openstreetmap.org/relation/6812187/#map=11/59.8064/10.7206

Event Timeline

Haros created this task.Jul 12 2018, 6:43 PM
Restricted Application added subscribers: jeblad, Danmichaelo, jhsoby, Aklapper. · View Herald TranscriptJul 12 2018, 6:43 PM
Haros added a comment.Jul 16 2018, 8:12 AM

I just came across an example that is worse than some small islands outside Oslo.

Look at https://maps.wikimedia.org/?#9/60.1798/19.5790 and then zoom in one step from level 9 to level 10 and you drown the home of nearly 30 000 people.

Jhernandez triaged this task as Low priority.Aug 7 2018, 3:46 PM
Jhernandez edited projects, added Maps (Map-Styles); removed Maps.
Jhernandez added a subscriber: Jhernandez.

We don't have the resources right now to work on this, and it is probably solved on the new maps styles.

Reflecting reality on the priority.

Please keep an eye on the community wishlist later this and vote for better map styles!

Pikne added a subscriber: Pikne.Dec 21 2018, 6:36 PM

It seems that Gressholmen now displays as the surrounding bay area object has been edited to exclude it. However as per natural=bay wiki page it isn't required to exclude islands. I still see quite some missing islands overlapping bay areas (w648202691, r9048910) around Estonia.

Inspired by openstreetmap-carto patch mentioned above, I gave it a try:
https://github.com/kartotherian/osm-bright.tm2source/pull/69

@Pikne thanks for working on top of that, I will take a look! Were you able to test it? I am asking out of curiosity because I am working on a Docker-compose environment for Kartotherian.

Pikne added a comment.Dec 21 2018, 8:01 PM

@Pikne thanks for working on top of that, I will take a look! Were you able to test it?

No. I hope that someone else can test it.

This is great, a nice Christmas present to us all.

I don't know how I could test it, but if you need a place that has not been changed and where the problem is still visible, try
https://maps.wikimedia.org/?lang=nb#17/59.33994/18.44622

Compare with
https://www.openstreetmap.org/#map=15/59.3411/18.4445

Or you can look at https://maps.wikimedia.org/?lang=nb#10/60.0587/20.1572 or https://no.wikipedia.org/wiki/Mariehamn where there are some problems with Åland.

Tested the above patch and the output is the following:

For the current production environment we have:

Haros added a comment.Jan 8 2019, 11:34 AM

Looks correct to me.

MSantos closed this task as Resolved.Apr 12 2019, 4:31 PM
MSantos claimed this task.
Haros added a comment.Apr 18 2019, 8:18 AM

Thanks for getting this done. I have checked a few places, where there were problems, but all the maps seem to be updated by now.