CI is failing on all open patches due to Quibble 0.0.22
Closed, ResolvedPublic

Description

Since some minutes all open patches and postmerge builds are failing with inintelligible error messages like those at https://integration.wikimedia.org/ci/job/mwext-phpunit-coverage-docker-publish/1412/console. As such, I cannot add much more details as I don't know what's the cause. The result is that https://gerrit.wikimedia.org/r/#/q/status:open are all failing.

17:18:34 Digest: sha256:0e16c30b9b41b55f7c3129d5e5b0e3d0867a8068863cbeec8f4ecafa3a290843
17:18:34 Status: Downloaded newer image for docker-registry.wikimedia.org/releng/quibble-stretch:0.0.22
17:18:35 DEBUG:quibble.cmd:Running stages: 
17:18:35 DEBUG:quibble.cmd:ZUUL_PROJECT=mediawiki/extensions/StopForumSpam
17:18:35 INFO:quibble.cmd:Projects: mediawiki/core, mediawiki/skins/Vector, mediawiki/extensions/StopForumSpam, mediawiki/extensions/AbuseFilter, mediawiki/extensions/AntiSpoof, mediawiki/extensions/CheckUser, mediawiki/extensions/CodeEditor, mediawiki/extensions/EventLogging, mediawiki/extensions/WikiEditor
17:18:35 Traceback (most recent call last):
17:18:35   File "/usr/local/bin/quibble", line 11, in <module>
17:18:35     load_entry_point('quibble==0.0.0', 'console_scripts', 'quibble')()
17:18:35   File "/usr/local/lib/python3.5/dist-packages/quibble/cmd.py", line 528, in main
17:18:35     cmd.execute()
17:18:35   File "/usr/local/lib/python3.5/dist-packages/quibble/cmd.py", line 412, in execute
17:18:35     self.clone(projects_to_clone)
17:18:35   File "/usr/local/lib/python3.5/dist-packages/quibble/cmd.py", line 216, in clone
17:18:35     cache_dir=self.args.git_cache)
17:18:35   File "/usr/local/lib/python3.5/dist-packages/quibble/zuul.py", line 47, in clone
17:18:35     for x in project_branch:
17:18:35 TypeError: 'NoneType' object is not iterable
17:18:35 Build step 'Execute shell' marked build as failure
MarcoAurelio triaged this task as Unbreak Now! priority.
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptAug 28 2018, 5:25 PM

Change 455872 had a related patch set uploaded (by Legoktm; owner: Legoktm):
[integration/config@master] Revert "Switch Jenkins jobs to Quibble 0.0.22 containers"

https://gerrit.wikimedia.org/r/455872

Paladox updated the task description. (Show Details)Aug 28 2018, 5:26 PM
Paladox added a subscriber: Paladox.
Legoktm renamed this task from CI is failing on all open patches to CI is failing on all open patches due to Quibble 0.0.22.Aug 28 2018, 5:29 PM
Legoktm lowered the priority of this task from Unbreak Now! to High.
Legoktm added a subscriber: hashar.
Legoktm added a subscriber: Legoktm.

Lowering priority slightly since I reverted the quibble upgrade.

Mentioned in SAL (#wikimedia-releng) [2018-08-28T17:30:36Z] <legoktm> reverted back to previous quibble version (T203009)

Change 455872 merged by jenkins-bot:
[integration/config@master] Revert "Switch Jenkins jobs to Quibble 0.0.22 containers"

https://gerrit.wikimedia.org/r/455872

hashar closed this task as Resolved.Aug 28 2018, 5:40 PM
hashar claimed this task.
hashar reassigned this task from hashar to Legoktm.

Thank you for expeditiously identifying and fixing the issue.

Change 455877 had a related patch set uploaded (by Hashar; owner: Hashar):
[integration/quibble@master] Fix empty exception on empty --project-branch

https://gerrit.wikimedia.org/r/455877

hashar reopened this task as Open.Aug 28 2018, 5:54 PM
hashar removed a project: Patch-For-Review.

It is all my fault, I have not properly tested it :(

Change 455877 merged by jenkins-bot:
[integration/quibble@master] Fix empty exception on empty --project-branch

https://gerrit.wikimedia.org/r/455877

Change 455880 had a related patch set uploaded (by Hashar; owner: Hashar):
[integration/config@master] docker: quibble 0.0.23

https://gerrit.wikimedia.org/r/455880

Change 455880 merged by jenkins-bot:
[integration/config@master] docker: quibble 0.0.23

https://gerrit.wikimedia.org/r/455880

Change 455881 had a related patch set uploaded (by Hashar; owner: Hashar):
[integration/config@master] Switch Jenkins jobs to Quibble 0.0.23 containers

https://gerrit.wikimedia.org/r/455881

Mentioned in SAL (#wikimedia-releng) [2018-08-28T18:04:43Z] <hasharAway> Rebuilding Docker quibble containers to use Quibble 0.0.23 | T203009

hashar closed this task as Resolved.Aug 28 2018, 6:58 PM

Change 455881 merged by jenkins-bot:
[integration/config@master] Switch Jenkins jobs to Quibble 0.0.23 containers

https://gerrit.wikimedia.org/r/455881