Page MenuHomePhabricator

Next button is missing in UploadWizard again in InternetExplorer
Closed, ResolvedPublic

Description

People on Commons are reporting that the "next" button in UploadWizard is missing in the "release rights" step, preventing uploads to be completed. A screenshot is available here. Please monitor Commons:Help_desk#Uploading_a_file in case people report some more details there.

May or may not be related to T88576.

Event Timeline

El_Grafo created this task.Sep 27 2018, 3:47 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 27 2018, 3:47 PM

Cannot reproduce using https://commons.wikimedia.org/wiki/Special:UploadWizard?debug=true directly in Firefox 62.
Plus I see 5 license options instead of the 3 license options in https://drive.google.com/file/d/0B-A3QgIhsJm4S1JtWXJrZ2N6V1MwMEJsSEpVVVNvVmV5bjJJ/view

If Wiki Loves Monuments (or something else) is involved here, please provide exact steps (including links) to reproduce the problem. Thanks a lot!

(For recent similar problems, see T204939 and T201800.)

El_Grafo added a comment.EditedSep 28 2018, 8:06 AM

Seems to be an issue related to Internet Explorer: Using IE 11.0.85 on Windows 10 and the WLM-de campaign I get exactly the issue described above, and the preview thumbnail is missing as well:

Interestingly, if I use the plain Special:UploadWizard, pretty much everything in the "Release Rights" step is missing:

Firefox on Linux works like a charm:

matthiasmullie added a subscriber: matthiasmullie.EditedSep 28 2018, 8:21 AM

Given the timing and similarity, it looks like the fix for T204939 may have introduced this.
I'm also unable to reproduce this issue, though.

In order to track down what's going on, it would be very helpful to know:

  • if this issue is happening in campaigns (which?)
  • if users have configured a default license in their preferences

UPDATE: I only just now saw the above comment - let's see if that helps me reproduce

I can only speak for myself, of course:

matthiasmullie added a comment.EditedSep 28 2018, 9:06 AM

Confirmed: this is affecting IE users (plain UW or campaigns) due to the use of Object.values. Other browsers support it so those are fine.
Patch is coming up. Apologies for the inconvenience!

Change 463437 had a related patch set uploaded (by Matthias Mullie; owner: Matthias Mullie):
[mediawiki/extensions/UploadWizard@master] Object.values is not supported in IE10

https://gerrit.wikimedia.org/r/463437

Aklapper renamed this task from Next button is missing in UploadWizard again to Next button is missing in UploadWizard again in InternetExplorer.Sep 28 2018, 9:18 AM

Change 463437 merged by jenkins-bot:
[mediawiki/extensions/UploadWizard@master] Object.values is not supported in IE

https://gerrit.wikimedia.org/r/463437

PeterEasthope added a subscriber: PeterEasthope.EditedSep 28 2018, 7:08 PM

If the Wizard is invoked by Epiphany Web 3.6.1 in the OLPC OS customized Redhat, the upload appears to complete but there is no "Next" button for progress to release of rights.

http://easthope.ca/CommonsUploadFromXO.png

[olpc@xo-53-1d-bb ~]$ uname -a
Linux xo-53-1d-bb.localdomain 3.3.8_xo1.5-20140611.1154.olpc.355c89e #1 PREEMPT Wed Jun 11 11:58:31 EST 2014 i686 i686 i386 GNU/Linux

This is a Linux system. I don't know about Object.values but the fault is not restricted to IE.

Regards, ... Peter E.

That may be the same issue, the problem affects all browsers not supporting ECMAScript 6 (ECMAScript 2015) methods – which includes a number of older browsers, but IE 11 is the most popular of them. If your browser is older than 2015 (and apparently that's a version from 2014), it probably doesn't support ECMAScript 2015 :)

(The issue will probably be fixed on the Wikimedia sites on Monday. We avoid doing software deployments on Friday and weekends unless it's something critical, like the while site being down.)

"... probably be fixed on the Wikimedia sites on Monday."

OK for me. No hurry warranted. Can test again Monday afternoon or later.

For sake of interest, might a functional file submission interface be built with plain old HTML5? Data entry fields but no scripting on the client side. Input checking on the server side.

Thanks, ... P.

It already exists at https://commons.wikimedia.org/wiki/Special:Upload (well, there is some minimal scripting, but it's optional).

This also affects Microsoft's Internet Explorer Mobile. 😟

matthiasmullie closed this task as Resolved.EditedOct 4 2018, 2:40 PM
matthiasmullie claimed this task.

The fix has been deployed - seems to work for me now!