Page MenuHomePhabricator

UploadWizard: 'Continue' button is not working: "Unable to set property 'licenseMaps' of undefined or null reference"
Closed, ResolvedPublic

Description

Not sure this is continue of T202760. I've made video of upload process: https://www.dropbox.com/s/yv9gqpch2mydgqk/Untitled%2017.mov?dl=0

Issues:

  • I cannot click Continue after licence claim
  • When I select I want to add licence later I see there are errors in the form even if there are none

Reproduction steps

Event Timeline

Yarl created this task.Sep 20 2018, 11:51 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 20 2018, 11:51 AM
Braveheart added a comment.EditedSep 20 2018, 11:58 AM

Works with https://commons.wikimedia.org/wiki/special:uploadWizard?campaign=wlm-at&id=6381&descriptionlang=de&description=Kath.+Pfarrkirche+hl.+Josef&categories=Cultural+heritage+monuments+in+Gro%C3%9F-Enzersdorf , haven't read any complaints so far.

Edit: When using Yarl's link, I get the message "Unable to set property 'licenseMaps' of undefined or null reference" in the IE11 console. Maybe there's something wrong with the campaign?

Aklapper triaged this task as Unbreak Now! priority.Sep 20 2018, 12:03 PM

Confirming. No output in the developer tools' console when trying with debug=true either.

Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptSep 20 2018, 12:03 PM
Aklapper renamed this task from UploadWizard: 'Continue' button is not working (again?) to UploadWizard: 'Continue' button is not working: "Unable to set property 'licenseMaps' of undefined or null reference".Sep 20 2018, 12:03 PM

Confirmed too.

Works if i click « Utiliser une licence différente » / « Pick a different license », select either of licences, and the click Continue.

@Yarl this seems to only affect campaigns without default licenses, that's why wikidaheim-at still works.

Change 462505 had a related patch set uploaded (by Matthias Mullie; owner: Matthias Mullie):
[mediawiki/extensions/UploadWizard@master] Tweak some default license inconsistencies

https://gerrit.wikimedia.org/r/462505

Yeah, it's because none of the available licenses match the default ownwork default license of cc-by-sa-4.0.
I've submitted a patch that should fix this. In the meantime, one could set the default license in the campaign's config.

Yarl added a comment.Sep 25 2018, 8:48 AM

In the meantime, one could set the default license in the campaign's config.

Is this proper fix? https://commons.wikimedia.org/w/index.php?diff=prev&oldid=321754108

Honestly? At that point I doubt we will ever do photo contest again that depends on UploadWizzard.

Ugh. Yes, that's exactly what I assumed could temporarily unbreak it, bit it appears it's not working on Commons.
I'll try to figure out why that is.
Meanwhile, I'll try to get that fix deployed as soon as possible.

Change 462505 merged by jenkins-bot:
[mediawiki/extensions/UploadWizard@master] Tweak some default license inconsistencies

https://gerrit.wikimedia.org/r/462505

Change 462780 had a related patch set uploaded (by Jforrester; owner: Matthias Mullie):
[mediawiki/extensions/UploadWizard@wmf/1.32.0-wmf.23] Tweak some default license inconsistencies

https://gerrit.wikimedia.org/r/462780

Change 462781 had a related patch set uploaded (by Jforrester; owner: Matthias Mullie):
[mediawiki/extensions/UploadWizard@wmf/1.32.0-wmf.22] Tweak some default license inconsistencies

https://gerrit.wikimedia.org/r/462781

Change 462780 merged by jenkins-bot:
[mediawiki/extensions/UploadWizard@wmf/1.32.0-wmf.23] Tweak some default license inconsistencies

https://gerrit.wikimedia.org/r/462780

Change 462781 merged by jenkins-bot:
[mediawiki/extensions/UploadWizard@wmf/1.32.0-wmf.22] Tweak some default license inconsistencies

https://gerrit.wikimedia.org/r/462781

Jdforrester-WMF closed this task as Resolved.Sep 25 2018, 11:50 PM
Jdforrester-WMF assigned this task to matthiasmullie.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

This should now be fixed in production. Sorry about the bug.