UploadWizard: Detail screen stays empty, publishing not possible
Closed, ResolvedPublicAug 31 2018

Description

Users on de:wp have been reporting an issue with the UploadWizard where the detail screen (last step) stays empty. It is therefore not possible to upload any pictures with the UploadWizard (at least with campaigns).

Link used: https://commons.wikimedia.org/wiki/special:uploadWizard?campaign=wlpa-at-601&id=1680&lat=47.091056&lon=15.4035&descriptionlang=de&description=o.T.+%28Wknr.+115+C%29

The error message in the IE11 console is:

jQuery.Deferred exception: Object doesn't support property or method 'setElementGroup' TypeError: Object doesn't support property or method 'setElementGroup'

at OO.ui.mixin.GroupElement.prototype.insertItem (https://commons.wikimedia.org/w/load.php?debug=false&lang=de&modules=ext.wikimediaEvents%7Cjquery%2Coojs-ui-core%2Coojs-ui-widgets%7Cjquery.lengthLimit%7Cjquery.makeCollapsible.styles%7Cmediawiki.confirmCloseWindow%2Cfeedback%2Chtmlform%7Coojs-ui.styles.icons-editing-core%2Cicons-location&skin=monobook&version=0vn246d:208:824)
at oo.EmitterList.prototype.addItems (Unknown script code:17:917)
at OO.ui.mixin.GroupElement.prototype.addItems (https://commons.wikimedia.org/w/load.php?debug=false&lang=de&modules=ext.wikimediaEvents%7Cjquery%2Coojs-ui-core%2Coojs-ui-widgets%7Cjquery.lengthLimit%7Cjquery.makeCollapsible.styles%7Cmediawiki.confirmCloseWindow%2Cfeedback%2Chtmlform%7Coojs-ui.styles.icons-editing-core%2Cicons-location&skin=monobook&version=0vn246d:208:454)
at UWCategoriesDetailsWidget (ht

Users have reported the same issue with FireFox: https://de.wikipedia.org/wiki/Wikipedia_Diskussion:WikiDaheim#Upload_Wizzard

Details

Due Date
Aug 31 2018, 12:00 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 24 2018, 6:15 PM
Herzi.Pinki triaged this task as High priority.Aug 26 2018, 10:18 AM

we are running a photo competition in Austria (wikidaheim) and we need the automated process for the bloody beginners urgently.

and please add the upload with campaign to the standard regression tests

Yarl added a subscriber: Yarl.Aug 26 2018, 5:43 PM

Same for Polish contest WikiVacations. Reproduction URL

Ramsey-WMF added a subscriber: MarkTraceur.
Ramsey-WMF added a subscriber: Ramsey-WMF.

Assigning to Matthias for now unless @MarkTraceur wants to take it.

Zache added a subscriber: Zache.Aug 27 2018, 8:32 AM

Confirmed in fiwiki's WLM campaing too.

Change 455532 had a related patch set uploaded (by Matthias Mullie; owner: Matthias Mullie):
[mediawiki/extensions/UploadWizard@master] Fix category multiwidget with default entries

https://gerrit.wikimedia.org/r/455532

Great work so far. Any chance we can expedite releasing this fix, @MarkTraceur or @matthiasmullie ?

Great work so far. Any chance we can expedite releasing this fix, @MarkTraceur or @matthiasmullie ?

Saturday is the start of WLM and thus the start of the heaviest trafic to the Upload Campaigns of the year.

Actually, competition already started in Ireland (as well as WikiDaheim in Austria and WikiVacations in Poland). This is rather urgent indeed.

Actually, competition already started in Ireland. This is rather urgent indeed.

We are directing all uploads through Monumental, so seem to be getting around this issue. However, Monumental is tagging uploads as being part of the 2017 competition, Romaine is currently running bots on the images as a fix for the moment.

Ramsey-WMF raised the priority of this task from High to Unbreak Now!.Aug 28 2018, 4:09 PM
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptAug 28 2018, 4:09 PM

Change 455532 merged by jenkins-bot:
[mediawiki/extensions/UploadWizard@master] Fix category multiwidget with default entries

https://gerrit.wikimedia.org/r/455532

If MW-1.32-release-notes (WMF-deploy-2018-09-04 (1.32.0-wmf.20)) means deployment on Sept. 4th (while WLM starts at Sept. 1st and WikiDaheim is running since the beginning of July) this seems a bit to late. Would it be possible to shift the deployment of this fix to before Sept. 1st? regards

Thinh68 renamed this task from UploadWizard: Detail screen stays empty, publishing not possible to Thinh6688.Aug 28 2018, 7:23 PM
Thinh68 lowered the priority of this task from Unbreak Now! to High.
Thinh68 claimed this task.
Thinh68 set Due Date to Aug 28 2028, 12:00 AM.
Thinh68 set the point value for this task to 1000.
Thinh68 added a subscriber: matthiasmullie.
Restricted Application changed the subtype of this task from "Task" to "Deadline". · View Herald TranscriptAug 28 2018, 7:23 PM
Ahonc awarded a token.Aug 28 2018, 7:26 PM
NickK added a subscriber: NickK.Aug 28 2018, 7:26 PM

Please do deploy it earlier than 4 September. We really need it for Wiki Loves Monuments to be ready on 31 August. All Ukraine's Wiki Loves Monuments list have a direct link to Upload Wizard that currently are not working. If it is absolutely impossible to get them ready by 31 August please give us the planned date so that we inform participants (and remove links that do not work). Thanks

NickK renamed this task from Thinh6688 to UploadWizard: Detail screen stays empty, publishing not possible.Aug 28 2018, 7:30 PM
NickK changed Due Date from Aug 28 2028, 12:00 AM to Aug 31 2018, 12:00 AM.
NickK reassigned this task from Thinh68 to matthiasmullie.
NickK raised the priority of this task from High to Unbreak Now!.
NickK added a subscriber: Thinh68.
Aklapper removed the point value for this task.Aug 28 2018, 7:42 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

The bot was wrong, because this got merged so close to the cut; this made it to the train for wmf.19, so is in production now on group0 wikis and will be on Commons tomorrow.

matthiasmullie closed this task as Resolved.Aug 30 2018, 6:27 AM

Fix has been deployed & it seems to be working just fine again!

Braveheart added a comment.EditedAug 30 2018, 7:44 AM

Thanks Matthias!

There is an overarching issue here though - this is about the fourth time this year that UploadWizard didn't work partially (or this time, at all). Is there something we can do to make sure that new versions/fixes don't break UploadWizard again? It's quite frustrating to set up a contest with intricate uploadlinks (one very cool feature of UploadWizard) and then for newbies not being able to use it for a week.

Best