Page MenuHomePhabricator

WikimediaMessages build fails on mwgate-npm-node-6-docker
Closed, ResolvedPublic

Description

08:05:02 Running "eslint:all" (eslint) task
08:05:03 
08:05:03 /src/Gruntfile.js
08:05:03   1:1  error  'module' is not defined  no-undef
08:05:03 
08:05:03 /src/modules/rcfilters-highlight-tour-hooks.js
08:05:03   2:1  warning  Line 2 exceeds the maximum line length of 100  max-len
08:05:03 
08:05:03 /src/modules/wlfilters-intro-tour.js
08:05:03   47:1  warning  Line 47 exceeds the maximum line length of 100  max-len
08:05:03 
08:05:03 ✖ 3 problems (1 error, 2 warnings)

https://integration.wikimedia.org/ci/job/mwgate-npm-node-6-docker/49817/console

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 15 2018, 8:14 AM
Nikerabbit triaged this task as Unbreak Now! priority.Oct 15 2018, 8:14 AM
Restricted Application added subscribers: Liuxinyu970226, TerraCodes. · View Herald TranscriptOct 15 2018, 8:14 AM
MarcoAurelio added a subscriber: MarcoAurelio.EditedOct 15 2018, 9:29 AM

This is weird. I don't know why this is suddenly failing. As far as I can see from the eslint docs, this might be caused by the extends: wikimedia from the .eslintrc.json file, which applies https://github.com/wikimedia/eslint-config-wikimedia. But that has been sitting there for a while without any issues, so I'm not sure why this is failing now.

Change 467296 had a related patch set uploaded (by MarcoAurelio; owner: MarcoAurelio):
[mediawiki/extensions/WikimediaMessages@master] Disable 'module' in .eslintrc.json

https://gerrit.wikimedia.org/r/467296

Change 467296 abandoned by MarcoAurelio:
Disable 'module' in .eslintrc.json

https://gerrit.wikimedia.org/r/467296

npm ERR! Failed at the @ test script 'grunt test'.
11:41:34 npm ERR! Make sure you have the latest version of node.js and npm installed.
11:41:34 npm ERR! If you do, this is most likely a problem with the  package,
11:41:34 npm ERR! not with npm itself.
11:41:34 npm ERR! Tell the author that this fails on your system:
11:41:34 npm ERR!     grunt test
11:41:34 npm ERR! You can get information on how to open an issue for this project with:
11:41:34 npm ERR!     npm bugs 
11:41:34 npm ERR! Or if that isn't available, you can get their info via:
11:41:34 npm ERR!     npm owner ls 
11:41:34 npm ERR! There is likely additional logging output above.
11:41:34 
11:41:34 npm ERR! Please include the following file with any support request:
11:41:34 npm ERR!     /src/npm-debug.log

CI issue?

hashar removed a subscriber: hashar.Oct 15 2018, 11:26 AM

This made the test pass, but I'm not sure if this is the desired solution? Please advice.

Change 467336 had a related patch set uploaded (by Jforrester; owner: MarcoAurelio):
[mediawiki/extensions/WikimediaMessages@master] build: Remind eslint that Gruntfile.js runs inside node

https://gerrit.wikimedia.org/r/467336

Change 467336 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@master] build: Remind eslint that Gruntfile.js runs inside node

https://gerrit.wikimedia.org/r/467336

Jdforrester-WMF closed this task as Resolved.Oct 15 2018, 4:24 PM
Jdforrester-WMF assigned this task to MarcoAurelio.
Jdforrester-WMF removed a project: Patch-For-Review.
Restricted Application added a project: User-MarcoAurelio. · View Herald TranscriptOct 15 2018, 4:24 PM