Page MenuHomePhabricator

CX2: Broken reference adaptation with interference from nearby links
Closed, InvalidPublic

Description

English article paragraph:

The '''Statue of Unity''' is a monument dedicated to [[Indian independence movement]] leader [[Vallabhbhai Patel]]<ref name="Aditya Thakur">{{cite news|title=14 Things You Did Not Know about Sardar Patel, the Man Who United India|url=http://topyaps.com/sardar-patel-the-ironman|accessdate=16 May 2014|newspaper=Topyaps|date=1 November 2014|author=Ashwani Sharma}}</ref> located in the Indian state of [[Gujarat]]. It is located facing the [[Narmada Dam]], {{cvt|3.2|km}} away on the river island called Sadhu Bet near [[Vadodara]] in Gujarat. The monument along with its surroundings occupies over 20,000 square meters, and is surrounded by a 12 square km artificial lake.<ref>http://www.statueofunity.in/brochure.html</ref> It is the world's [[List of tallest statues|tallest statue]] with the height of {{convert|182|metres}}.<ref name="bk">{{cite news | url=http://articles.timesofindia.indiatimes.com/2012-08-22/ahmedabad/33321734_1_tallest-statue-narmada-dam-narmada-river | title=Burj Khalifa consultant firm gets Statue of Unity contract | work=[[The Times of India]] | date=22 August 2012 | agency=TNN | accessdate=28 March 2013}}</ref>

And problematic adaption:

'''સ્ટેચ્યુ ઓફ યુનિટી''' [[ભારતીય સ્વતંત્રતા ચળવળ|ભારતીય સ્વતંત્રતા ચળવળના]] નેતા [[વલ્લભભાઈ પટેલ]]<sup href="./Gujarat" rel="mw:WikiLink"><nowiki>[1]</nowiki></sup> ને સમર્પિત ગુજરાત, ભારતમાં આવેલું એક સ્મારક છે. તે [[સરદાર સરોવર બંધ|નર્મદા બંધ]]<nowiki/>ની સામે {{cvt|3.2|km}} દૂર નદીમાં આવેલા સાધુ બેટ પર વડોદરા નજીક આવેલું છે. આ સ્મારકનો વિસ્તાર ૨૦,૦૦૦ ચોરસ મીટર છે અને તે ૧૨ ચોરસ કિ.મી. વિસ્તારના કૃત્રિમ તળાવ વડે ઘેરાયેલું છે.<sup class="cx-segment-block"><span href="./List_of_tallest_statues" rel="mw:WikiLink">[2]</span></sup> ૧૮૨ મીટરની ઊંચાઇ સાથે આ સ્મારક વિશ્વની સૌથી ઊંચી પ્રતિમા છે.<sup class="cx-segment-block"><span href="./Government_of_Gujarat" rel="mw:WikiLink">[3]</span></sup>

Logs from Parsoid/CX (In reverse order):

Encountered <a class="cx-segment" data-segmentid="78"><span about="#mwt26" class="mw-ref" data-cx="{&quot;adapted&quot;:true}" id="cite_ref-8" rel="dc:references" typeof="mw:Extension/ref">[1]</span><span about="#mwt26" class="mw-ref" data-cx="{&quot;adapted&quot;:true}" id="cite_ref-8" rel="dc:references" typeof="mw:Extension/ref">[2]</span></a> -- serializing as extlink and dropping <a> attributes unsupported in wikitext.

href is missing from a tag <a class="cx-segment" data-segmentid="78"><span about="#mwt26" class="mw-ref" data-cx="{&quot;adapted&quot;:true}" id="cite_ref-8" rel="dc:references" typeof="mw:Extension/ref">[1]</span><span about="#mwt26" class="mw-ref" data-cx="{&quot;adapted&quot;:true}" id="cite_ref-8" rel="dc:references" typeof="mw:Extension/ref">[2]</span></a>

Encountered <a class="cx-segment" data-segmentid="71"><span class="cx-link" data-linkid="72" href="./Government_of_Gujarat" id="mwFA" rel="mw:WikiLink" title="Government of Gujarat">[3]</span></a> -- serializing as extlink and dropping <a> attributes unsupported in wikitext.

Encountered <a class="cx-segment" data-segmentid="69"><span class="cx-link" data-linkid="70" href="./List_of_tallest_statues" id="mwEg" rel="mw:WikiLink" title="List of tallest statues">[2]</span></a> -- serializing as extlink and dropping <a> attributes unsupported in wikitext.

href is missing from a tag <a class="cx-segment" data-segmentid="69"><span class="cx-link" data-linkid="70" href="./List_of_tallest_statues" id="mwEg" rel="mw:WikiLink" title="List of tallest statues">[2]</span></a>

href is missing from a tag <a class="cx-segment" data-segmentid="71"><span class="cx-link" data-linkid="72" href="./Government_of_Gujarat" id="mwFA" rel="mw:WikiLink" title="Government of Gujarat">[3]</span></a>

href is missing from a tag <a class="cx-segment-block"><span data-segmentid="65" class="cx-segment">[1]</span></a>

Event Timeline

KartikMistry triaged this task as Medium priority.Oct 23 2018, 3:40 PM
KartikMistry created this task.
Restricted Application added subscribers: jeblad, Aklapper. · View Herald TranscriptOct 23 2018, 3:40 PM
KartikMistry updated the task description. (Show Details)Oct 23 2018, 3:42 PM

So the issue seems that the original template with all the details turns into weird markup that is affected somehow by a nearby link. For example, the sentence with the first reference has a link to Gujarat at the end:

<ref name="Aditya Thakur">{{cite news|title=14 Things You Did Not Know about Sardar Patel, the Man Who United India|url=http://topyaps.com/sardar-patel-the-ironman|accessdate=16 May 2014|newspaper=Topyaps|date=1 November 2014|author=Ashwani Sharma}}</ref> located in the Indian state of [[Gujarat]].

A similar issue happens with the second reference and the nearby link to "List of tallest statues"
That link seems to confuse the process of adapting the reference resulting in the following:

<sup href="./Gujarat" rel="mw:WikiLink"><nowiki>[1]</nowiki></sup>

Pginer-WMF renamed this task from CX2: Broken reference adaption (multiple cases) to CX2: Broken reference adaption with interference from nearby links.Oct 24 2018, 7:21 AM
Arrbee moved this task from Needs Triage to Bugs on the ContentTranslation board.Oct 29 2018, 1:01 PM
Amire80 renamed this task from CX2: Broken reference adaption with interference from nearby links to CX2: Broken reference adaptation with interference from nearby links.Nov 4 2018, 1:09 PM

As per the master version of cxserver and MW CX,
This is the Yandex translation and adaptation result for the first para of en:Statue of Unity revision=865364435

આ '''સ્ટેચ્યુ ઓફ યુનિટી''' એક સ્મારક માટે સમર્પિત [[ભારતીય સ્વતંત્રતા ચળવળ|ભારતીય સ્વતંત્રતા ચળવળના]] નેતા [[વલ્લભભાઈ પટેલ]]<ref name="Aditya Thakur">{{Cite news|title=14 Things You Did Not Know about Sardar Patel, the Man Who United India|url=http://topyaps.com/sardar-patel-the-ironman|access-date=16 May 2014|work=Topyaps|date=1 November 2014|last=Ashwani Sharma}}</ref> માં સ્થિત ભારતીય રાજ્ય [[ગુજરાત]]છે. તે સ્થિત થયેલ છે સામનો [[સરદાર સરોવર બંધ|નર્મદા ડેમ]], {{Cvt|3.2|km}} દૂર નદી પર ટાપુ કહેવાય સાધુ હોડ નજીક [[વડોદરા|વડોદરા,]] ગુજરાત. આ સ્મારક સાથે તેની આસપાસના રોકે પર 20,000 ચોરસ મીટર, અને એ દ્વારા ઘેરાયેલો એક 12 ચોરસ કિ. મી કૃત્રિમ તળાવ છે.<ref><div>http://www.statueofunity.in/brochure.html</div></ref> તે વિશ્વની સૌથી ઊંચી પ્રતિમા સાથે ઊંચાઈ {{Convert|182|metres}}છે.<ref name="bk">{{Cite news|url=http://articles.timesofindia.indiatimes.com/2012-08-22/ahmedabad/33321734_1_tallest-statue-narmada-dam-narmada-river|title=Burj Khalifa consultant firm gets Statue of Unity contract|work=[[The Times of India]]|date=22 August 2012|agency=TNN|access-date=28 March 2013}}</ref> સરદાર વલ્લભભાઈ પટેલ Rashtriya Ekta ટ્રસ્ટ (SVPRET), એક ખાસ હેતુ વાહન સ્થાપના કરવામાં આવી હતી દ્વારા [[ગુજરાત સરકાર]] માટે તેના બાંધકામ અને આઉટરીચ કાર્યક્રમ હાથ ધરવામાં આવી હતી સમગ્ર ભારતમાં શરૂ વર્ષનો બારમો મહિનો 2013.<ref name="iron">{{Cite news|url=http://m.timesofindia.com/city/ahmedabad/Statue-of-Unity-36-new-offices-across-India-for-collecting-iron/articleshow/24306198.cms|title=Statue of Unity: 36 new offices across India for collecting iron|work=[[The Times of India]]|date=18 October 2013|agency=TNN|access-date=30 October 2013}}</ref>

And produces this HTML rendering. I fail to see any issues in it

So, I am not able to reproduce issue. Is there a chance that the content got corrupt after the manual edits on top of it? VE is pretty good in preventing that. So what happened?!

So, I am not able to reproduce issue. Is there a chance that the content got corrupt after the manual edits on top of it? VE is pretty good in preventing that. So what happened?!

@KartikMistry are you still able to reproduce the issue? can you share more details?

So, I am not able to reproduce issue. Is there a chance that the content got corrupt after the manual edits on top of it? VE is pretty good in preventing that. So what happened?!

@KartikMistry are you still able to reproduce the issue? can you share more details?

Now, it looks good. Same result as @santhosh noted.

We can close this bug.

Note extra <div> tag in <ref><div>http://www.statueofunity.in/brochure.html</div></ref> though. I'm not sure why it has been added.

Pginer-WMF closed this task as Invalid.Nov 19 2018, 9:22 AM

Note extra <div> tag in <ref><div>http://www.statueofunity.in/brochure.html</div></ref> though. I'm not sure why it has been added.

This may be the same this user reported. We can create a separate ticket for this.

Note extra <div> tag in <ref><div>http://www.statueofunity.in/brochure.html</div></ref> though. I'm not sure why it has been added.

This may be the same this user reported. We can create a separate ticket for this.

Follow-up ticket created: T210276: CX2: Avoid unnecessary extra divs in references
@KartikMistry feel free to comment or expand the details in the new ticket if it does not cover your case.