Page MenuHomePhabricator

Simple English not shown in “Languages” section of pages for interwiki linking
Closed, ResolvedPublic

Description

It was brought up on Simple Talk that Simple English isn’t shown under any of the geographically sorted languages. (See: https://simple.wikipedia.org/wiki/Wikipedia:Simple_talk#Getting_to_simple_articles_from_English)

To test this, I went to [[Ronald Reagan]] on the English Wikipedia and tried to find a link to the Simple English Wikipedia, where it is a Very Good Article. I checked each geographically sorted section of the Languages popup, as well as searching for Simple, and was unable to find it.

Event Timeline

Adotchar created this task.Nov 30 2018, 2:29 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptNov 30 2018, 2:29 PM
Aklapper renamed this task from Simple English not shown in “Languges” section of pages for interwiki linking to Simple English not shown in “Languages” section of pages for interwiki linking.Dec 2 2018, 11:04 AM
Restricted Application added a project: UniversalLanguageSelector. · View Herald TranscriptDec 14 2018, 2:38 PM
Amire80 triaged this task as High priority.Dec 28 2018, 1:51 PM
Amire80 moved this task from Backlog to Missing languages on the ULS-CompactLinks board.
Amire80 added a subscriber: Amire80.

I can reproduce it.

High priority, because the point of Compact Language Links is supposed to be making access to languages easier, and all missing languages bugs are high-priority.

I'll try to fix ASAP.

Change 491213 had a related patch set uploaded (by KartikMistry; owner: Amire80):
[mediawiki/extensions/UniversalLanguageSelector@master] Update jquery.uls from upstream

https://gerrit.wikimedia.org/r/491213

This should be tested carefully for the affected languages at least in:

  • Special:Translate
  • Special:LanguageStats
  • CX article selector
  • CX gray interlanguage links
  • ULS compact links
  • ULS language selector
  • ULS language search
Cohaf added a subscriber: Cohaf.Apr 15 2019, 1:23 PM
Arrbee added a subscriber: Arrbee.Apr 17 2019, 7:30 AM

@Amire80 @KartikMistry what is the next step here? This is a high priority ticket with an open patch that has not been reviewed for close to a month. Should this be deprioritized?

@Amire80 @KartikMistry what is the next step here? This is a high priority ticket with an open patch that has not been reviewed for close to a month. Should this be deprioritized?

I believe it requires more extensive careful testing as @Nikerabbit suggested above. Maybe we can put it in backlog until we all are available for testing.

Moving to blocked until @Amire80 is back and we have clarity on how the tests have to be done.

Change 491213 abandoned by Amire80:
Update jquery.uls from upstream

Reason:
The big BCP 47 update will be done some other time, hopefully soon.

https://gerrit.wikimedia.org/r/491213

Amire80 closed this task as Resolved.May 25 2019, 4:21 PM