Page MenuHomePhabricator

cxserver: TypeError: Cannot read property '_options' of null
Closed, ResolvedPublic

Description

cxserver seems broken in master and throws following error:

URL: https://cxserver.wmflabs.org/v2

{"status":500,"type":"internal_error","title":"TypeError","detail":"Cannot read property '_options' of null","method":"GET","uri":"/v2"}

(will add detailed log here soon..)

Details

Related Gerrit Patches:
mediawiki/services/cxserver : masterGuard against non-configured ratelimiter

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 13 2018, 3:38 PM
KartikMistry triaged this task as High priority.Dec 13 2018, 3:38 PM
KartikMistry closed this task as Declined.Dec 13 2018, 4:04 PM

Probably caused by outdated config.yaml in Labs. Will open if issue still there..

Please enable the rate limiter. A non configured rate limiter is causing this issue.

santhosh reopened this task as Open.Dec 14 2018, 6:30 AM

Change 479588 had a related patch set uploaded (by Santhosh; owner: Santhosh):
[mediawiki/services/cxserver@master] Guard against non-configured ratelimiter

https://gerrit.wikimedia.org/r/479588

Petar.petkovic moved this task from Backlog to Other on the CX-cxserver board.Dec 14 2018, 11:43 AM

Change 479588 merged by jenkins-bot:
[mediawiki/services/cxserver@master] Guard against non-configured ratelimiter

https://gerrit.wikimedia.org/r/479588

Etonkovidova closed this task as Resolved.Dec 19 2018, 10:42 PM
Stashbot added a subscriber: Stashbot.

Mentioned in SAL (#wikimedia-operations) [2018-12-20T12:43:33Z] <kartik@deploy1001> Started deploy [cxserver/deploy@16f65cb]: Update cxserver to 803baa4 (T210581, T211889, T144467, T209473)

Mentioned in SAL (#wikimedia-operations) [2018-12-20T12:48:15Z] <kartik@deploy1001> Finished deploy [cxserver/deploy@16f65cb]: Update cxserver to 803baa4 (T210581, T211889, T144467, T209473) (duration: 04m 42s)