Page MenuHomePhabricator

Please add Brazilian Portuguese (pt-br) language to Phabricator
Open, Stalled, MediumPublic

Description

Add Brazilian Portuguese language to phabricator

translatewiki

Event Timeline

Eduaddad created this task.Feb 9 2019, 2:13 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 9 2019, 2:13 PM
MarcoAurelio renamed this task from Add language to Please add Brazilian Portuguese (pt-br) language to Phabricator.Feb 9 2019, 2:17 PM
MarcoAurelio added a project: Phabricator.
MarcoAurelio added a subscriber: MarcoAurelio.

[ modified title and tags to better reflect the request - see how to report a bug ]

MarcoAurelio moved this task from Untriaged to Phabricator on the I18n board.
Eduaddad removed a subscriber: Eduaddad.Feb 9 2019, 4:04 PM
Eduaddad added a subscriber: Eduaddad.
Eduaddad updated the task description. (Show Details)

Removing Language-Team as this has nothing to do with the Language Team (see description) and it is up to each team what they plan to work on

Eduaddad triaged this task as Medium priority.Jul 23 2019, 6:33 PM
Aklapper raised the priority of this task from Medium to Needs Triage.Jul 23 2019, 7:12 PM

@Aklapper

I translated most resources to phabricator.

Ah, thank you for that! :) I'm not sure how the process works to deploy translations, to be honest. :-/

The translations get uploaded periodically from translatewiki.net and then I compile and deploy them with the next phabricator deployment window. All together it usually takes a week or more to make it's way into production.

Eduaddad added a comment.EditedJul 23 2019, 7:51 PM

So how much Brazilian Portuguese language will be available?

@mmodell

I see a lot of pt-br strings in rPHTR7a91b1b79c72: Localisation updates from https://translatewiki.net. and that will be deployed with the next phabricator update.

Is it too slow to deploy?

@mmodell

@Eduaddad As far as I know, while translatewiki.net translations get uploaded to the Phabricator repo automatically, @mmodell has to compile them manually afterwards. That's why it takes more time.

@mmodell and @MarcoAurelio

is the language available?

mmodell reopened this task as Open.Jul 24 2019, 1:16 AM

Not until at least tomorrow.

mmodell triaged this task as Medium priority.Jul 24 2019, 1:16 AM
This comment was removed by Eduaddad.

is the language available? @mmodell

@Eduaddad: Please look at T215697#5359784 which answers your question. Thanks.

@Eduaddad: Yes, obviously it is. Is anything unclear?

(I'm not sure what is the intention behind asking the same question again and again.)

right and I'll wait

FWIW I don't manage Phabricator translations so I cannot do anything to speed up or slow down the process. I shall note however that I can't see T215697#5359784. It appears as {C2} to me (like Tasks and Objects I am not allowed to see). I thought I should mention it. Regards.

so the language team is not allowed to add translations to the program?

so the language team is not allowed to add translations to the program?

Phabricator has its own updating/deployment process which is different from the regular language updates Wikimedia wikis do get.

Mentioned in SAL (#wikimedia-operations) [2019-08-15T00:03:20Z] <twentyafterfour> starting phabricator upgrade to 2019-08-14/1 refs T215697

This is published but phabricator doesn't show the language because it currently has less than 500 strings translated.

Wondering: Should this task be resolved?

This is published but phabricator doesn't show the language because it currently has less than 500 strings translated.

3202 texts have been translated in translatewiki.net

Is it checking those 500 strings in some specific module? If so, I would like to document this on the project page.

mmodell added a comment.EditedAug 20 2019, 7:08 AM

It just checks how many strings are in a given locale and arbitrarily hides them when there are less than 512 total strings.

This is the upstream change: rPHAB2f93ce4c25be: Don't show "Limited" or "Test" translations unless an install is in developer…

See line 78:

if ($size > 512 || $is_english) {
  $type = 'normal';
} else {
  $type = 'limited';
}

I think for this install it might make sense to change the threshold to something quite a lot smaller than 512.

As for the number of translations on translatewiki.net, perhaps some of them aren't making it through the conversion to phabricator translation classes?

https://translatewiki.net/w/i.php?title=Special:MessageGroupStats&language=fi&group=phabricator#sortable:3=desc Hungary is available in Phabricator settings, but many languages above it are not.

It is important to investigate why, because this could mean that some translator effort is wasted and we care a lot about not doing that.

$ find . -name "pt-br.json" | xargs cat | grep : | wc -l
1987
$ find . -name "*PtBr.php" | xargs cat | grep '=>' | wc -l
1926

I see one problem - in the locales definition I see the language code listed as pt-br but in the translation classes it's pt_Br.

Ok this should be fixed by rPHTR244773670a3c: Fixed locale code mapping between Phabricator and translatewiki.

I should be able to get the patch deployed tomorrow (Wednesday August 20th at approximately Midnight UTC)

This looks much better:

Great❣ Thanks for looking into this and fixing it.

How long is the translation update done?

@mmodell

Was the translation 100% added?

@Eduaddad: What do you mean by 100% added? I added all the translations that were available as of Wednesday, you can see all of the changes in this commit: rPHTR244773670a3c

because I think a lot of translation is missing or I did the translation in the wrong place

@mmodell

how often is the translation updated?

@Eduaddad it's updated 2 to 3 times each month.

I'm not sure what could be the problem, I'll double check that I didn't miss anything.

I realize that some of my translations were not placed

Thank you so much for verifying the implementation

Eduaddad added a comment.EditedSep 22 2019, 2:46 AM

@mmodell

the error still continues

translations translated before March and April 2019 are not here

https://translatewiki.net/wiki/Phabricator:phabricator-core-b0dd737a679b9166/pt-br

I'm not sure what the cause of the problem is.

mmodell changed the task status from Open to Stalled.Oct 8 2019, 6:09 PM

Would it be worth closing this issue as resolved, as Brazilian Portuguese is now available in Phab? Then for any remaining issues, one or more separate issues can be opened that contain more details not related directly to adding generic pt-br support.

the language is in error and the translations were done but are still in English in Phabricator

.Nafees791 renamed this task from Please add Brazilian Portuguese (pt-br) language to Phabricator to add.Jan 23 2020, 4:07 AM
.Nafees791 closed this task as Declined.
.Nafees791 removed mmodell as the assignee of this task.
.Nafees791 raised the priority of this task from Medium to High.
.Nafees791 updated the task description. (Show Details)
.Nafees791 removed subscribers: siebrand, Nikerabbit, mmodell and 2 others.
DannyS712 renamed this task from add to Please add Brazilian Portuguese (pt-br) language.Jan 23 2020, 5:07 AM
DannyS712 reopened this task as Stalled.
DannyS712 assigned this task to mmodell.
DannyS712 lowered the priority of this task from High to Medium.
DannyS712 updated the task description. (Show Details)
DannyS712 added subscribers: siebrand, Nikerabbit, mmodell and 2 others.
Aklapper renamed this task from Please add Brazilian Portuguese (pt-br) language to Please add Brazilian Portuguese (pt-br) language to Phabricator.Jan 23 2020, 10:16 AM