Page MenuHomePhabricator

Caption edit does not save
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce:
When logged out, go to: https://commons.wikimedia.org/wiki/File:Apoteka_Milete_Leskovca.jpg
Try to correct the typo in the English caption and click "Publish".

Actual Results:
Nothing happens--caption does not save and no error message is shown.

Expected Results:
Caption should save.

Details

Related Gerrit Patches:
mediawiki/extensions/WikibaseMediaInfo : wmf/1.33.0-wmf.25Fall back to old config var name
mediawiki/extensions/WikibaseMediaInfo : masterFall back to old config var name

Event Timeline

Abit created this task.Apr 10 2019, 9:59 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 10 2019, 9:59 PM
Abit added a comment.Apr 10 2019, 10:07 PM

Huh, works now, and on files in similar categories. Not sure what happened :/

I confirmed that it didn't work, then made an edit to it while logged in, and that worked. When I logged out and tried to make an edit again...it worked the second time around. So you can't use those steps above to reproduce it anymore, it seems :(

My best guess is that it has something to do with the GLAM template on that page?

Ramsey-WMF removed Ramsey-WMF as the assignee of this task.Apr 10 2019, 10:09 PM
Ramsey-WMF moved this task from Untriaged to Needs Reproduction on the Multimedia board.

There is a bug here...but it seems intermittent/tricky to track down. Thoughts, @Cparle or @matthiasmullie ?

Abit added a comment.Apr 10 2019, 10:37 PM

Here's a fresh image on which I could not save a caption while logged out: https://commons.wikimedia.org/wiki/File:Alberi_AlpediSiusi.JPG

The page inspection tells me, " null?action=wbgetentities&format=json&props=info%7Clabels&ids=M4643338:1 Failed to load resource: the server responded with a status of 404 () "

Ramsey-WMF triaged this task as Medium priority.Apr 10 2019, 10:41 PM
Ramsey-WMF moved this task from Needs Reproduction to Next up on the Multimedia board.

I can no longer reproduce this, but I believe this is related to https://gerrit.wikimedia.org/r/c/mediawiki/extensions/WikibaseMediaInfo/+/500006.
I can prepare a quick little something to fix this if it persists, but I think it's just browser cache, which should refresh soon (or try a hard refresh or clearing your browser cache)

Change 502949 had a related patch set uploaded (by Matthias Mullie; owner: Matthias Mullie):
[mediawiki/extensions/WikibaseMediaInfo@master] Fall back to old config var name

https://gerrit.wikimedia.org/r/502949

Is T220651 a duplicate of this task? If so, please feel free to merge via "Edit Related Tasks... 🡒 Merge Duplicates In" here on T220665.

@Aklapper it's not. It looks like T220651 got fixed last night, while this only started then. Responded on that ticket.

About this one: this is happening because the variable used in JS is included in the HTML output: you're getting new (post-JS, uncached) JS trying to get a variable from a (locally) cached page (must've visited the page recently, it must not have changed, and your browser must not yet have expunged the cache)
I have a fix ready that we can deploy if needed should we get more reports, but I suspect this will fix itself soon enough as local caches get refreshed.

Change 502949 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Fall back to old config var name

https://gerrit.wikimedia.org/r/502949

Change 503062 had a related patch set uploaded (by Jforrester; owner: Matthias Mullie):
[mediawiki/extensions/WikibaseMediaInfo@wmf/1.33.0-wmf.25] Fall back to old config var name

https://gerrit.wikimedia.org/r/503062

Change 503062 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@wmf/1.33.0-wmf.25] Fall back to old config var name

https://gerrit.wikimedia.org/r/503062

Mentioned in SAL (#wikimedia-operations) [2019-04-11T22:15:31Z] <jforrester@deploy1001> Synchronized php-1.33.0-wmf.25/extensions/WikibaseMediaInfo/resources/: Hot-deploy fix for WBMI variable cache miss T220665 (duration: 00m 55s)

Ramsey-WMF closed this task as Resolved.Apr 24 2019, 12:07 AM

Have not been able to reproduce this in a while, nor on production, so considering it closed.