Page MenuHomePhabricator

backport pdns-server version 3.x to Stretch
Closed, ResolvedPublic

Description

The default pdns version on stretch is 4.0. The docs for the pdns backend in designate/mitaka say "This backend will not work with PowerDNS version 4 or greater. Use the pdns4 backend" but the pdns4 backend is not available until designate newton.

Related Objects

Event Timeline

Andrew created this task.May 25 2019, 8:50 PM
Restricted Application removed a project: Patch-For-Review. · View Herald TranscriptMay 25 2019, 8:50 PM

Change 512734 had a related patch set uploaded (by Arturo Borrero Gonzalez; owner: Arturo Borrero Gonzalez):
[operations/puppet@production] openstack: designate: mitaka: stretch: use pdns 3.x

https://gerrit.wikimedia.org/r/512734

Change 512734 merged by Andrew Bogott:
[operations/puppet@production] openstack: designate: mitaka: stretch: use pdns 3.x

https://gerrit.wikimedia.org/r/512734

Change 512744 had a related patch set uploaded (by Andrew Bogott; owner: Andrew Bogott):
[operations/puppet@production] pdns3hack: don't pin pdns-recursor to the old repo

https://gerrit.wikimedia.org/r/512744

Change 512744 merged by Andrew Bogott:
[operations/puppet@production] pdns3hack: don't pin pdns-recursor to the old repo

https://gerrit.wikimedia.org/r/512744

aborrero closed this task as Resolved.May 31 2019, 4:45 PM
aborrero claimed this task.

This should be fixed AFAIK. Closing task now. Hopefully, we will upgrade openstack soon and we will drop this hack.