Page MenuHomePhabricator

Add baserevid to wblremovesense API module
Open, Needs TriagePublic

Description

See parent.

Event Timeline

Ladsgroup created this task.Jun 5 2019, 9:56 AM
Restricted Application removed a project: Patch-For-Review. · View Herald TranscriptJun 5 2019, 9:56 AM

Change 517414 had a related patch set uploaded (by Ladsgroup; owner: Ladsgroup):
[mediawiki/extensions/WikibaseLexeme@master] Add baserevid to wblremovesense API module

https://gerrit.wikimedia.org/r/517414

Addshore moved this task from incoming to in progress on the Wikidata board.Jun 21 2019, 11:25 PM
WMDE-leszek added a subscriber: WMDE-leszek.

Tests failing in a why that suggests something is not fully working, hence putting this back to Doing.

Tests failing in a why that suggests something is not fully working, hence putting this back to Doing.

It was just a typo in the commit message

waaat, I was looking at what could be wrong in the code, and missed the Depens thing. thanks for fixing.

Change 517414 merged by jenkins-bot:
[mediawiki/extensions/WikibaseLexeme@master] Add baserevid to wblremovesense API module

https://gerrit.wikimedia.org/r/517414

I have these Lexeme with a Sense and a Form. 2 editors (A and B)
B edits the Lexeme by removing the form.
few seconds after, A tries to edit the Lexeme by removing the Sense and gets an Error: sense Id not found. A only succeed after reloading the page

I have these Lexeme with a Sense and a Form. 2 editors (A and B)
B edits the Lexeme by removing the form.
few seconds after, A tries to edit the Lexeme by removing the Sense and gets an Error: sense Id not found. A only succeed after reloading the page

I repeated and got a different output, it works just fine: https://wikidata.beta.wmflabs.org/w/index.php?title=Lexeme:L52&action=history

(Did you make sure to refresh the page after you added senses/forms?)

(Did you make sure to refresh the page after you added senses/forms?)

Oops! sorry. Thank you