Page MenuHomePhabricator

In de.wiktionary admins (again!!) no longer can grant the right for "autoreview" (passiver Sichter) or "editor" (Sichter).
Closed, ResolvedPublic

Description

Again (as in T225115) in de.wiktionary admins no longer can grant the right for "autoreview" (passiver Sichter) or "editor" (Sichter).

In addition, today a user automatically became "editor" (Sichter), see https://de.wiktionary.org/wiki/Spezial:Logbuch?type=rights&user=Peter+Berbe

This automatism for "editor" (Sichter) is not provided in de.wikt. In de.wikt there was so far only an automatism for "autoreview" (passiver Sichter).

Best regards
Udo T.

Event Timeline

Udo_T created this task.Jun 24 2019, 2:58 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 24 2019, 2:58 PM
Udo_T triaged this task as High priority.Jun 24 2019, 2:58 PM
Udo_T updated the task description. (Show Details)Jun 24 2019, 3:01 PM
JJMC89 added a subscriber: Reedy.Jun 24 2019, 3:01 PM
Udo_T updated the task description. (Show Details)Jun 24 2019, 3:02 PM
Aklapper raised the priority of this task from High to Needs Triage.Jun 24 2019, 4:04 PM
Reedy added a comment.Jun 24 2019, 4:25 PM

In addition, today a user automatically became "editor" (Sichter), see https://de.wiktionary.org/wiki/Spezial:Logbuch?type=rights&user=Peter+Berbe
This automatism for "editor" (Sichter) is not provided in de.wikt. In de.wikt there was so far only an automatism for "autoreview" (passiver Sichter).

This part should already be fixed (you might need to remove the group from the account)

Udo_T added a comment.Jun 24 2019, 4:39 PM

Hi @Reedy, but we can't remove the group from the account, because no admin is able, to grant (or remove) the right for "autoreview" (passiver Sichter) or "editor" (Sichter). (Part 1 of the task).

Berst regards
Udo T.

Udo_T added a comment.Jun 24 2019, 4:41 PM

The same behavior as in T225115 a few weeks ago.

Reedy added a comment.Jun 24 2019, 4:42 PM

Again (as in T225115) in de.wiktionary admins no longer can grant the right for "autoreview" (passiver Sichter) or "editor" (Sichter).

Do you know if that broke today, or has it been broken since last Tuesday?

https://github.com/wikimedia/operations-mediawiki-config/commit/014c42f0d1efd84651c1d48321a263109e00284d#diff-e5cc5cd3aad93462d5d6a1249360a419

Cause I think it was broken by this:

Mentioned in SAL (#wikimedia-operations) [2019-06-18T12:03:09Z] <urbanecm@deploy1001> Synchronized wmf-config/flaggedrevs.php: [[:gerrit:517629|Allow sysops to manage flaggedrevs group membership only if the group exists]] (T225797) (duration: 00m 47s)

Not by the changes I've made today...

Udo_T added a comment.Jun 24 2019, 4:45 PM

I am not sure. We became aware of it today because the user Peter Berbe automatically became an editor. Udo T.

@Reedy: It doesn't look this was caused by my change. When I was deploying that change, I verified it's working correctly on several wikis, including dewiktionary.

Udo_T added a comment.Jun 24 2019, 5:01 PM

Hi @Reedy. can you possibly still set up the config so that the admins can grant (or revoke) "autoreview" and "editor" again?

Best regards
Udo T.

Reedy added a comment.EditedJun 24 2019, 5:01 PM

@Reedy: It doesn't look this was caused by my change. When I was deploying that change, I verified it's working correctly on several wikis, including dewiktionary.

Indeed, I think you're right, sorry. It's been a long afternoon

I'm not sure why, but wgAddGroups and wgRemoveGroups don't seem to being pulled through by extreg (but it WFM locally). I think it might be due to the default in IS.php that doesn't include it... And extreg takes that as it doesn't need to do it for some reason. Patch to partially revert my patch and bring your code back in is incoming

Probably need to file a separate task for that...

Change 518759 had a related patch set uploaded (by Reedy; owner: Reedy):
[operations/mediawiki-config@master] Fix AddGroups/Remove groups for editor/autoreview

https://gerrit.wikimedia.org/r/518759

Change 518759 merged by jenkins-bot:
[operations/mediawiki-config@master] Fix AddGroups/RemoveGroups for editor/autoreview

https://gerrit.wikimedia.org/r/518759

Mentioned in SAL (#wikimedia-operations) [2019-06-24T17:10:52Z] <reedy@deploy1001> Synchronized wmf-config/flaggedrevs.php: T226410 (duration: 00m 54s)

Reedy closed this task as Resolved.Jun 24 2019, 5:11 PM
Reedy claimed this task.
Reedy removed a project: Patch-For-Review.
Udo_T added a comment.Jun 24 2019, 5:13 PM

@Reedy: Many thanks for the quick help. Now it works again.

Best regards
Udo T.

Udo_T removed a subscriber: Udo_T.Jun 24 2019, 5:17 PM
Udo_T added a subscriber: Udo_T.Jun 24 2019, 11:26 PM

Hi @Reedy,

About 2 hours ago, another user automatically became "editor" (Sichter), see https://de.wiktionary.org/wiki/Spezial:Logbuch?type=rights&user=Hans-Friedrich+Tamke

Can you please deactivate this automatism to become "editor" (Sichter) in de.wiktionary?

In de.wiktionary we only have an automatism for "autoreview" (passiver Sichter), but NOT for "editor" (Sichter).

Best regards
Udo T.

Udo_T reopened this task as Open.Jun 24 2019, 11:35 PM

In de.wiktionary we only have an automatism for "autoreview" (passiver Sichter), but NOT for "editor" (Sichter).

Are you sure?

Are there definitely isn't an autopromote config for dewiktionary for any groups...

Udo_T added a comment.Jun 25 2019, 8:37 AM

Hi @Reedy, yes, i'm very sure.

As you can see in the 2 logs https://de.wiktionary.org/wiki/Spezial:Logbuch?type=rights&user=Hans-Friedrich+Tamke and https://de.wiktionary.org/wiki/Spezial:Logbuch?type=rights&user=Peter+Berbe
the user "Hans Friedrich Tamke" became automatically "autoreview" (passiver Sichter) on "00:19, 23. Mär. 2013" and the user "Peter Berbe" became automatically "autoreview" (passiver Sichter) on "21:37, 24. Jun. 2018".

You can also see the requirements for autopromote of "autoreview" (passiver Sichter) in task T46103

Best regards
Udo T.

Reedy added a comment.Jun 25 2019, 8:40 AM

I guess it's because it's not autopromote, it's autoconfirm from T46103

Why does it have multiple overly complex things that do vaguely the same thing... Ugh

Udo_T added a comment.Jun 25 2019, 8:46 AM

I don't know why. But it works fine all the years.

The problem now ist NOT the automatism for "autoreview" (passiver Sichter). That's ok and that is what we want.

But since a few days users are becoming automatically "editor" (Sichter). And that's NOT ok for us.

Best regards
Udo T.

Reedy added a comment.Jun 25 2019, 8:48 AM

I don't know why. But it works fine all the years.
The problem now ist NOT the automatism for "autoreview" (passiver Sichter). That's ok and that is what we want.
But since a few days users are becoming automatically "editor" (Sichter). And that's NOT ok for us.
Best regards
Udo T.

Yes, I know. It should've been fixed again as of last night, hopefully

https://github.com/wikimedia/operations-mediawiki-config/commit/a3866b4caa9e3eb689ee1ed4e36aa293844575bf#diff-e5cc5cd3aad93462d5d6a1249360a419

I'm trying to work on tidying this stuff up to make things cleaner/easier and less complex so these things hopefully don't happen again

Udo_T added a comment.Jun 25 2019, 8:54 AM

Ok, thank you for the info. I will watch the "user rights log" in de.wiktionary.

If the problem should reappear, then I'll get back here again.

Best regards
Udo T.

Aklapper closed this task as Resolved.Jun 29 2019, 11:56 AM

Closing as per last comment. If this happens again, please set the status of this report back to "Open" via the Add Action...Change Status dropdown. Thanks!

Tgr added a subscriber: Tgr.Tue, Jul 30, 10:31 AM

This broke the config for wikis which do *not* want admins to be able to grant those rights. (Ain't flagrev config a bundle of fun?)