Page MenuHomePhabricator

Convert button doesn't display since wmf.16
Closed, ResolvedPublic

Description

Steps to reproduce

  1. Go to https://cs.wikipedia.org/w/index.php?title=Za_%C4%BEud%C3%AD&oldid=17535284
  2. Open the article in VE
  3. Click any reference with only URL
  4. Expected: There should be "Convert" button, allowing users to convert it to fully featured reference, like in screenshot.
  5. Observed: There is no "Convert" button.

Event Timeline

Urbanecm created this task.Sat, Aug 3, 6:51 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSat, Aug 3, 6:51 PM
Janbery added a subscriber: Janbery.Sat, Aug 3, 6:54 PM
jeblad added a subscriber: jeblad.Sun, Aug 4, 1:10 PM

Also happen at nowiki.

Schnark added a subscriber: Schnark.

Since this works in mobile editor, I'm going to blame rECEX46014698791a: Move convert ref button to footer when the footer exists (even though that is wmf.16, not wmf.15).

Mvolz triaged this task as High priority.Mon, Aug 5, 10:01 AM

Change 528109 had a related patch set uploaded (by Esanders; owner: Esanders):
[VisualEditor/VisualEditor@master] Only create context footer on mobile

https://gerrit.wikimedia.org/r/528109

Change 528109 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] Only create context footer on mobile

https://gerrit.wikimedia.org/r/528109

Urbanecm renamed this task from Convert button doesn't display since wmf.15 to Convert button doesn't display since wmf.16.Mon, Aug 5, 12:38 PM

Since this works in mobile editor, I'm going to blame rECEX46014698791a: Move convert ref button to footer when the footer exists (even though that is wmf.16, not wmf.15).

(my typo, sorry, fixed)

Change 528173 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (32693b706)

https://gerrit.wikimedia.org/r/528173

Change 528253 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (aae84a489)

https://gerrit.wikimedia.org/r/528253

Change 528173 abandoned by Jforrester:
Update VE core submodule to master (ab6d942c5)

Reason:
Ed pushed Ic03c22a785a instead.

https://gerrit.wikimedia.org/r/528173

Change 528253 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (aae84a489)

https://gerrit.wikimedia.org/r/528253

Mvolz moved this task from Backlog to Waiting on Deploy on the Citoid board.Thu, Aug 8, 1:56 PM
matmarex edited projects, added Skipped QA; removed Editing QA.Fri, Aug 9, 4:52 PM
matmarex moved this task from QA to Product owner review on the VisualEditor (Current work) board.
matmarex added a subscriber: matmarex.

I checked myself that it works as expected again on https://cs.wikipedia.org/w/index.php?title=Za_%C4%BEud%C3%AD&oldid=17535284 (the fix is already live in production).

Checked enwiki and nowiki, and works for me.

Works fine in fawiki.

Ahmad252 lowered the priority of this task from High to Normal.Thu, Aug 15, 9:10 AM
Urbanecm closed this task as Resolved.Thu, Aug 15, 9:40 AM
Urbanecm assigned this task to Esanders.
Urbanecm raised the priority of this task from Normal to High.