Page MenuHomePhabricator

"convert" button doesn't correctly detect if Citoid is enabled; we shouldn't offer convert button and message if automatic tab also isn't enabled.
Closed, ResolvedPublicBUG REPORT

Description

In Prod example:

https://hi.wikipedia.org/wiki/राम_मूर्ति

Click on the first ref - it says click the convert button even though citoid is not enabled.

Event Timeline

Mvolz updated the task description. (Show Details)Aug 2 2019, 9:22 AM
Esanders renamed this task from "covert" button doesn't correctly detect if citoid is enabled; we shouldn't offer convert button and message if automatic tab also isn't enabled. to "convert" button doesn't correctly detect if Citoid is enabled; we shouldn't offer convert button and message if automatic tab also isn't enabled..Aug 2 2019, 8:19 PM
Esanders updated the task description. (Show Details)

This should be fixable in ve.ui.Citoid.init.js in the Citoid extension. 'auto' mode is available when ve.ui.mwCitoidMap is set, so we should check for this in ve.ui.MWReferenceContextItem.prototype.renderBody

Schnark removed a subscriber: Schnark.Aug 3 2019, 8:16 AM

@Esanders @Mvolz It appears that right now the Convert button doesn't show up anywhere.

Mvolz updated the task description. (Show Details)Aug 5 2019, 10:00 AM
Mvolz moved this task from Backlog to Extension on the Citoid board.Aug 8 2019, 1:56 PM

That's a different issue, T229734

matmarex updated the task description. (Show Details)Aug 8 2019, 6:56 PM

I asked to pull this into "Investigating" because I was very confused by the description. I think it was missing a "not", please check if that's right. Also, the issue is not reproducible at the given URL anymore, because Citoid was apparently enabled on the wiki. Is there another example?

Mvolz added a comment.Aug 9 2019, 9:50 AM

I asked to pull this into "Investigating" because I was very confused by the description. I think it was missing a "not", please check if that's right. Also, the issue is not reproducible at the given URL anymore, because Citoid was apparently enabled on the wiki. Is there another example?

There isn't another live example because it only occurs under the following conditions:

The MediaWiki:Visualeditor-cite-tool-definition.json is defined
The MediaWiki:Citoid-template-type-map.json message is defined, but incorrectly, i.e. is missing required keys.

If both are undefined then old style citation is used without the inspector.

I fixed the broken config in the live example.

Ideally this shouldn't happen but it did here!

matmarex moved this task from To Triage to Triaged on the VisualEditor board.Feb 12 2020, 5:24 PM
srishakatux added a subscriber: srishakatux.

Hi! I'm removing the good first task as this task doesn't seem to have clear next steps and lacks getting started instructions for a new contributor. If you disagree, put back the tag and add any necessary information in the task description.

Change 576018 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/Citoid@master] Don't show convert message if 'auto' mode is not available

https://gerrit.wikimedia.org/r/576018

Change 576018 merged by jenkins-bot:
[mediawiki/extensions/Citoid@master] Don't show convert message if 'auto' mode is not available

https://gerrit.wikimedia.org/r/576018

matmarex edited projects, added Skipped QA; removed Patch-For-Review.

(Skipping QA because the bug is not reproducible on any Wikimedia wiki right now)

marcella closed this task as Resolved.Mar 4 2020, 5:30 PM
marcella awarded a token.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMar 4 2020, 5:30 PM