Technical Collaboration quarterly goals for April - June 2016
Closed, ResolvedPublic

Description

Team quarterly goals

This is the first quarter where we start the quarterly goals process from scratch as Technical Collaboration team. We don't have Community-Relations-Support and Developer-Advocacy team goals anymore.

The canonical location of the Technical Collaboration team goals for April - June 2016 is https://meta.wikimedia.org/wiki/Technical_Collaboration/Goals. They are copied here for convenience:

Individual quarterly goals

Individual goals are documented in the table below.

OwnerGoals
@AklapperT129068: Improve code contribution guidelines for patch authors; T129067: Document a structured, standardized approach for reviewing code contributions
@CKoerner_WMFT125525: Update Discovery Team pages to be more consistent and organized T127296: Better promotion of smaller tech events (Tech Talks, Office Hours, Lightning Talks...) T128109: Investigate Maps Detail Level with Communities
@ElitreT96500: Q4 personal goal: Facilitate deployment of VisualEditor at Phase 6 wikis, T130533: Q4 personal goal: start building a volunteer, cross-wiki taskforce to help with the community side of VE work
@JohanT128790: Translation strategy – act and refine, T125961: Find out where to put not strictly technical news, T133510: First draft of timeline of WMF technical development
@KeeganT131883: Communication workflows between WMF Product teams and Wikimedia communities , T130241: Goal Q4: Document decision making in communities around software , T121260: Q4 Goal: Internal work on product design and development principles and process
@MoushiraT130010: Experiment with “user interaction” consultation , T122287: Community engagement around "Read more" as a stable feature on mobile and/or desktop, T113618: Start mediawiki (kind of multilingual) Hovercards RfC
@RfarrandT131914: Technical Collaboration participation in Wikimania , T132398: Developer Summit: Research Other Venues , T132107: Publish Lessons Learned from Wikimedia Hackathon 2016
@QgilT124019: Define the Technical Collaboration annual plan FY2016-17 - T130624: Wikimania session "Analyzing conflict and possible solutions around WMF software development" - T110170: Goal: Deploy Newsletter extension in Wikimedia
@QuiddityT130095: A plan for the top ten Community Wishlist tasks driven by volunteers - T123570: Cross-wiki notifications - announcements planning - T132624: Pre-Wikimania Hackathon 2016 Content Work
@Trizek-WMFT129088: Create an easy to maintain glossary to facilitate documentation translation (help pages and technical documentation) T113490: 10 tips for communicating with communities when developing software
@Whatamidoing-WMFT129387: Inform communities about the planned outage caused by the codfw server change

Calendar

  • 7 March: department goals. If we want one of our team goals to be promoted as a Community Engagement goal, we need to push it before this deadline
  • 16 March: team goals defined -- changes are still possible as part of the internal review
  • 1 April: latest date for publication of department goals
  • 5 July: Quarterly review slides due to Maggie by end of day
  • 6 July: @Qgil and @Keegan run through slides during Community Engagement directors meeting, finalize for sending to WMF executive team that day
  • 11 July: Community Engagement quarterly review. Quarterly review slides. Technical Collaboration starts in page 16, and there is more information in the Appendices (page 41).

Related Objects

StatusAssignedTask
ResolvedQgil
ResolvedKeegan
ResolvedKeegan
DeclinedNone
ResolvedKeegan
ResolvedKeegan
ResolvedKeegan
ResolvedJohan
ResolvedQuiddity
Resolved Moushira
ResolvedRfarrand
ResolvedQgil
ResolvedJohan
ResolvedTrizek-WMF
ResolvedAklapper
Resolvedsiebrand
ResolvedRfarrand
ResolvedRfarrand
ResolvedQuiddity
ResolvedQgil
ResolvedLadsgroup
ResolvedLadsgroup
ResolvedTrizek-WMF
ResolvedAklapper
OpenNone
ResolvedTrizek-WMF
DeclinedTrizek-WMF
Resolvedmatej_suchanek
ResolvedMvolz
OpenNone
ResolvedMvolz
ResolvedTrizek-WMF
ResolvedMvolz
ResolvedNone
ResolvedMvolz
ResolvedMvolz
ResolvedAcamicamacaraca
ResolvedMvolz
ResolvedTiven2240
ResolvedMvolz
ResolvedNone
OpenNone
OpenNone
DeclinedTrizek-WMF
ResolvedMvolz
OpenNone
ResolvedAklapper
ResolvedQuiddity
Qgil created this task.Mar 1 2016, 10:00 AM
Restricted Application added a subscriber: StudiesWorld. · View Herald TranscriptMar 1 2016, 10:00 AM
Qgil triaged this task as High priority.Mar 1 2016, 10:00 AM
Qgil updated the task description. (Show Details)Mar 2 2016, 9:55 PM
Johan updated the task description. (Show Details)Mar 3 2016, 9:27 PM
Qgil updated the task description. (Show Details)Mar 3 2016, 9:57 PM
Trizek-WMF updated the task description. (Show Details)Mar 4 2016, 3:57 PM
Qgil updated the task description. (Show Details)Mar 8 2016, 3:55 PM
Aklapper updated the task description. (Show Details)Mar 14 2016, 8:51 PM
Keegan updated the task description. (Show Details)Mar 14 2016, 9:01 PM
Johan updated the task description. (Show Details)Mar 16 2016, 6:42 AM
Qgil added a comment.Mar 17 2016, 11:24 AM

The current draft of the team goals has been posted at https://meta.wikimedia.org/wiki/Technical_Collaboration/Goals

Elitre updated the task description. (Show Details)Mar 21 2016, 2:51 PM
Johan updated the task description. (Show Details)Mar 22 2016, 8:03 AM
CKoerner_WMF updated the task description. (Show Details)Mar 22 2016, 3:08 PM
Qgil updated the task description. (Show Details)Mar 22 2016, 3:52 PM
Trizek-WMF updated the task description. (Show Details)Mar 22 2016, 4:02 PM
Moushira updated the task description. (Show Details)Mar 28 2016, 1:07 PM
Moushira updated the task description. (Show Details)
Qgil updated the task description. (Show Details)Mar 30 2016, 9:45 AM
Quiddity updated the task description. (Show Details)Apr 2 2016, 8:21 AM
Keegan updated the task description. (Show Details)Apr 5 2016, 7:59 PM
Keegan updated the task description. (Show Details)Apr 5 2016, 8:03 PM
Qgil added a comment.Apr 6 2016, 9:11 AM

The team quarterly goals are all clear now. We still have to polish some individual goals, but this is the unofficial part of this task, and it is mostly done anyway. Lowering priority and moving the task to July (quarterly review).

CKoerner_WMF updated the task description. (Show Details)Apr 12 2016, 3:40 PM
Johan updated the task description. (Show Details)Apr 24 2016, 9:39 PM
Rfarrand updated the task description. (Show Details)Apr 26 2016, 4:13 PM
Rfarrand updated the task description. (Show Details)
Qgil updated the task description. (Show Details)May 20 2016, 10:08 AM
Qgil raised the priority of this task from Low to High.Jun 29 2016, 9:15 AM
Qgil updated the task description. (Show Details)

T131914: Technical Collaboration participation in Wikimania , DONE

T132398: Developer Summit: Research Other Venues, technically DONE but the decision has not been finalized.

T132107: Publish Lessons Learned from Wikimedia Hackathon 2016, 1/4 DONE, will prioritize

Qgil updated the task description. (Show Details)Jul 29 2016, 3:21 PM
Qgil closed this task as Resolved.Jul 29 2016, 3:27 PM

@Keegan presented the Technical Collaboration part of the Community Engagement review on my behalf (I was on vacation). For what I have heard and read, everything went fine. I have linked to the slides from the description of this task and https://meta.wikimedia.org/wiki/Technical_Collaboration/Goals

In the next quarterly review I want to do better at capturing and evaluating the work we have done, and summarizing it in a digestible way for wider consumption. If you are interested in these improvement, please join me at T132499: Review KPIs, workflows, and scorecards of the Technical Collaboration team.

Thank you to everybody who contributed to Technical Collaboration's work during the past quarter!