Page MenuHomePhabricator

Enable citoid on fr.wikiversity
Closed, ResolvedPublic

Description

On fr.wikiversity, when I click on « Source » on the visual editor menu, the frame displaying

is different from other projets as fr.wikipedia
or even en.wikiversity
.
By the way there is no option for creating automatic bibliographic description from an URL, ISBN and so on.
Thanks to all of you for telling me if I can do something for fixing this as administrator of the project or fix it yourself if I can't do nothing.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 26 2018, 11:01 AM
Aklapper removed Dereckson as the assignee of this task.Jun 26 2018, 11:15 AM
Aklapper added a subscriber: Dereckson.

Hi, please do not assign tasks to people without their agreement.

I am not sure I understand the problem, as the screenshot for fr.wikiversity shows VisualEditor's "Insert" dropdown and an empty page, while the other screenshots do not show that dropdown but a context menu for a reference.
https://mediawiki.org/wiki/How_to_report_a_bug asks to please provide 1) steps to reproduce including URLs, 2) expected outcome, and 3) actual outcome.

By the way there is no option for creating automatic bibliographic description from an URL, ISBN and so on.

If that is the actual problem described in this task, then it has the same reason as T196866#4276720 - please follow https://www.mediawiki.org/wiki/Citoid/Enabling_Citoid_on_your_wiki

Hi, please do not assign tasks to people without their agreement.

Ok, I've just understand one minute ago than you are the dispatcher of task. Next time how can I do ? Adding you as subscriber or assignee you for the task ?

This comment was removed by Lionel_Scheepmans.
  1. steps to reproduce including URLs, 2) expected outcome, and 3) actual outcome.
  1. steps to reproduce including URLs : Starting the visual editor on any pages of fr.wikiversity (ex my sandbox page) with firefox 59.0.2 (64 bits) and vector skin , click on "source" in the menu, than "référence" on the next menu.
  2. expected outcome : I want to see the same as en.wikiversity : a frame whit "automatic" option
  3. actual outcome : I see only manual option for editing the citation.

How to do this ? :

The Citoid service uses VisualEditor's Citation Tool. This is already enabled on most large Wikipedias and many smaller projects. If the citation tool is enabled, then the "Source" menu will list one or more local citation templates, in addition to "Référence" and "Réutiliser". If the citation tool is not enabled, then you need to enable it before proceeding. Each citation template will require normal TemplateData to work.

It's look like I have to folow https://www.mediawiki.org/wiki/Help:TemplateData. But this is to dificult for my technical ability. Is there some one to assist me instead of pointing web pages withouth courtesy?

Lionel_Scheepmans added a subscriber: Mvolz.
Aklapper renamed this task from Add citation display issue on fr.wikiversity to "Add a citation" dialog on fr.wikiversity should offer "Automatic".Jun 26 2018, 1:30 PM
Aklapper added projects: VisualEditor, Citoid.
Mvolz renamed this task from "Add a citation" dialog on fr.wikiversity should offer "Automatic" to Enable citoid on fr.wikiversity.Jun 26 2018, 3:55 PM
Deskana triaged this task as Normal priority.Jun 26 2018, 6:36 PM
Deskana moved this task from To Triage to External and Administrivia on the VisualEditor board.
Mvolz added a comment.EditedJun 27 2018, 7:41 AM

It's look like I have to folow https://www.mediawiki.org/wiki/Help:TemplateData. But this is to dificult for my technical ability. Is there some one to assist me instead of pointing web pages withouth courtesy?

Hi,

Since citoid is enabled on fr wikipedia, a simple way to do it just to copy all the templates and messages from fr wikipedia, i.e.

Template:Ouvrage
Template:Lien web
Template:Chapitre
Template:Article

The template data is in the documentation page, so if you import the most recent doc page from fr wikipedia, the template data part is done.

and after the templates, the message:

https://fr.wikipedia.org/wiki/MediaWiki:Citoid-template-type-map.json

Mvolz moved this task from Backlog to Zotero on the Citoid board.Jul 2 2018, 12:14 PM
Lionel_Scheepmans raised the priority of this task from Normal to High.Oct 23 2018, 9:17 AM

Thanks a lot for your help ! Actually, citdoid display woks on fr.wikiversity find and build the reference

while it's works corectlly on fr.wikipedia with the same URL.
. I'm staying ready for giving more information.

@Deskana Hello, as your are the lasts person giving attention to this post and as you seem be part of the active team on phabricator, can you please tel me if this task keep the attention of some one ? I feel some time lonely front of issue concerning fr.wikiversity. Thanks again.

@Lionel_Scheepmans It looks like you've not fully followed @Mvolz's instructions above:

Since citoid is enabled on fr wikipedia, a simple way to do it just to copy all the templates and messages from fr wikipedia, i.e.
Template:Ouvrage
Template:Lien web
Template:Chapitre
Template:Article

It looks like some of these templates have been copied over (e.g,. Modèle:ouvrage exists) but others have not (e.g. Modèle:Chapitre does not exist). You should probably copy all the relevant templates over.

The template data is in the documentation page, so if you import the most recent doc page from fr wikipedia, the template data part is done.
and after the templates, the message:
https://fr.wikipedia.org/wiki/MediaWiki:Citoid-template-type-map.json

MediaWiki:Citoid-template-type-map.json on the French Wiktionary is null, which probably explains why Citoid isn't working.

You should finish copying over the relevant templates to the French Wiktionary, then copy over MediaWiki:Citoid-template-type-map.json from the French Wikipedia. When you've done that, if it's still not working, we can offer some advice on what might be wrong.

I'm afraid this isn't something the Editing team can do for you. The citation templates and structure used by each wiki is up to the users on that wiki, so we'd be overstepping our bounds if we started interfering in that process. Additionally, the Editing team doesn't have the capacity to set up Citoid on every one of the hundreds of wikis. Your expertise and knowledge of the standards on your wiki is better than ours. :-)

Ok @Deskana , I understand. Than for your help. I'll try my best with what I have understand. So, in an other place could you help me to fix an other issue concerning fr.wikiversity ? Here is : https://phabricator.wikimedia.org/T182669 Thx a lot for your help !

@Deskana , I'm back after doing your recommendations :

  • Copy past the 4 templates from fr.wikipedia

But on fr.wikiversity there is already a preexisting "template:Chapitre" used for lesson edition. So I've imported the "template:Chapitre" from fr.wikipedia but change the name to "template:Chapitre-B" (https://fr.wikiversity.org/wiki/Mod%C3%A8le:Chapitre-B)

  • Copy past MediaWiki:Citoid-template-type-map.json on the French Wiktionary and change the code "Chapitre" by "Chaptire-B" thinking than it should help the system to work.

But unfortunately, it still don't work as you can see below.


So, I still have to bother you again ...

@Deskana , I'm back after doing your recommendations :

  • Copy past the 4 templates from fr.wikipedia

But on fr.wikiversity there is already a preexisting "template:Chapitre" used for lesson edition. So I've imported the "template:Chapitre" from fr.wikipedia but change the name to "template:Chapitre-B" (https://fr.wikiversity.org/wiki/Mod%C3%A8le:Chapitre-B)

  • Copy past MediaWiki:Citoid-template-type-map.json on the French Wiktionary and change the code "Chapitre" by "Chaptire-B" thinking than it should help the system to work.

But unfortunately, it still don't work as you can see below.


So, I still have to bother you again ...

Hi,

I had a look and it looks like you added templatedata that was blank to the templates themselves. This blank template data will overwrite the template data in the documentation page.

I.e. https://fr.wikiversity.org/w/index.php?title=Mod%C3%A8le%3AOuvrage&type=revision&diff=739415&oldid=513968

I hope you don't mind but I have reverted those, the template data you added to the documentation pages was great. Should work now :)

Lionel_Scheepmans added a comment.EditedOct 30 2018, 12:45 PM

Hi,
I had a look and it looks like you added templatedata that was blank to the templates themselves. This blank template data will overwrite the template data in the documentation page.
I.e. https://fr.wikiversity.org/w/index.php?title=Mod%C3%A8le%3AOuvrage&type=revision&diff=739415&oldid=513968
I hope you don't mind but I have reverted those, the template data you added to the documentation pages was great. Should work now :)

Thanks a lot @Mvolz ! It's work now. The last thing weird was all the red sentences ( Logo du langage Lua
Ce modèle utilise le module Erreur d’expression : opérateur >= inattendu.Erreur d’expression : opérateur >=) on the beginning of the template: pages. That's coming from template:utilisant les modules Lua|Module:Biblio. So I've remove it from template:ouvrage page and it's look ok. If you have any comment about this, there are welcome. Cheers,

Mvolz closed this task as Resolved.Dec 11 2018, 11:33 AM
Mvolz lowered the priority of this task from High to Normal.