Fix the automatic cite feature of VisualEditor in Sundanese Wikipedia
Closed, ResolvedPublic0 Story Points

Description

The automatic feature of cite-web or DOI is not working. I don't know why it' hapenned. Anyone can help me? please

Uchup19 created this task.Sep 24 2017, 11:45 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 24 2017, 11:45 AM

Hi @Uchup19, thanks for taking the time to report this!
Unfortunately this report lacks some information. If you have time and can still reproduce the problem: Please add a more complete description to this report (a list of steps to reproduce which leave no room for interpretation what to do, describing actual results and expected results after performing the steps to reproduce, attaching or linking to a public testcase, browser information, MediaWiki version information, etc). You can edit the task description by clicking Edit Task.
Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results. Problems that others can reliably reproduce can get fixed faster. Thanks!

Mvolz moved this task from Backlog to Zotero & External on the Citoid board.Oct 8 2017, 2:06 PM
Mvolz added a subscriber: Mvolz.Oct 8 2017, 2:36 PM

Hi @Uchup19, thanks for reporting- sorry it took so long to get back to you. I've temporarily removed the mediawiki namespace message (https://su.wikipedia.org/w/index.php?title=M%C3%A9diaWiki%3ACitoid-template-type-map.json&type=revision&diff=530936&oldid=528478) until the template data is fixed, since it is not currently working.

There are two problems:

  1. Some of the templates in that message are missing. So for instance, where it says "Citation", that corresponds to https://su.wikipedia.org/wiki/Citakan:Citation, which does not yet exist. You can either import this template, or you can use a different template in the message there instead. (i.e. Cite web)
  2. Some templates which do exist don't have a citoid 'maps' value in the template data. It is needed in every template that is in the message. See step 2a: https://www.mediawiki.org/wiki/Citoid/Enabling_Citoid_on_your_wiki#Step_2.a:_Create_a_.27citoid.27_maps_value_for_each_Cite_template.C2.A0

As a first step, you can try adding a 'maps' value to Cite web. Let me know if you need any further help. I am happy to look at the template after this information is added to check it.

To sum up these are the problems:

Citakan:Citation is missing
Citakan:Cite web is missing citoid 'maps' in template data
Citakan:Cite book - works! Look at this as an example
Citakan:Cite journal is a stub - do you have a template you typically use instead of this one?
Citakan:Cite news missing all template data, including citoid 'maps'

Mvolz closed this task as Resolved.Oct 10 2017, 7:05 AM
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptOct 10 2017, 7:05 AM
Jdforrester-WMF set the point value for this task to 0.Oct 11 2017, 4:03 PM