Page MenuHomePhabricator

Newly registered user cant save contributions
Closed, ResolvedPublic

Description

One of my colleagues created a Wikimedia account especially to contribute to ISA. After having created the new, fresh account, she logs in ito ISA, allows the OAuth screen, goes to an ISA campaign, add a Wikidata-tag... now she wants to save her contribution, but that does not work

This might be intended behaviour (perhaps new users must first have made a certain treshhold number of contribs??), but in that case that should be cleary communicated in the ISA tool itself

Details

Related Gerrit Patches:
operations/mediawiki-config : masterIncrease rate limits for newbie non-ip users

Event Timeline

@OlafJanssen Do you know if your colleague was able to add structured data on Wikimedia Commons itself?

@SandraF_WMF Yes, I also showed her that as well. The idea of ISA is to show her an easier tool, which acts better on mobile. Also, the idea of running campaigns is of added value compared to the WMC-interface

I got the error myself now as well a couple of times...

@MarkTraceur @matthiasmullie - per discussion in backlog grooming today will research increasing the edit rate limits on Commons to reduce the odds of this error happening

@OlafJanssen It's not immediately clear to me exactly what's going on.
Did the new user start seeing this error message immediately, when the very first thing was being submitted? (in which case this is probably some yet unknown bug)
Or was it only after having already submitted a few things that it showed up? (in which case I suspect the user was rate limited - only a certain amount of edits are allowed in a short period of time for new users)

I believe that we could raise the rate limits, given the real amount of actual useful structured data contributions that can be made in this short amount of time.

We currently do not distinguish between anons and other newbie (not autoconfirmed) users: both are allowed 120 edits per 15 minutes (an average of 8 per minute).
I propose we keep the current limits for anonymous users and increase the amount of allowed edits for new (registered, but not yet autoconfirmed) users to something like 120 edits per 5 minutes.
I suspect that limit is going to be hit drastically less compared to the current limits, while not opening up things for abuse too much since one would still need to go through the process of creating an account (and they can be blocked more easily than IPs.)

@MarkTraceur (who) do we need to consult before we do this?

It might also make sense for ISA to display a more informative error message (if at all possible.)
I believe that, in the case of being rate limited, the API response includes an error message like this: "As an anti-abuse measure, you are limited from performing this action too many times in a short space of time, and you have exceeded this limit.
Please try again in a few minutes."
The exact error messages returned from the API would provide more context as to what went wrong (and make it easier to troubleshoot what went wrong on the API's end, if the cause of the error is to be found there)

Change 541532 had a related patch set uploaded (by Matthias Mullie; owner: Matthias Mullie):
[operations/mediawiki-config@master] Increase rate limits for newbie non-ip users

https://gerrit.wikimedia.org/r/541532

@Spinster is following up with the ISA folks about this

Eugene233 moved this task from Backlog to Review on the ISA board.

Change 541532 merged by jenkins-bot:
[operations/mediawiki-config@master] Increase rate limits for newbie non-ip users

https://gerrit.wikimedia.org/r/541532

matthiasmullie closed this task as Resolved.Wed, Oct 30, 11:33 AM

Rate limits have been increased for registered & confirmed users.

Abit awarded a token.Thu, Oct 31, 3:24 PM