Page MenuHomePhabricator

ApiQueryMapData.php: Call to a member function getData() on null
Closed, ResolvedPublic

Description

Error
message
[XWfN3gpAMDkAAJ8XuPkAAABU] /w/api.php?format=json&formatversion=2&action=query&titles=Category%3APlay%20Mountain&prop=mapdata&mpdlimit=max&mpdgroups=_4d3f78e5cbfadc4057a015d74536ef07cb4bbab2   Error from line 42 of /srv/mediawiki/php-1.34.0-wmf.20/extensions/Kartographer/includes/ApiQueryMapData.php: Call to a member function getData() on null
Impact

5 hits in wmf.20. Not seen before that.

Notes

Blocking the train. Similar or duplicate of T231554: ApiQueryMapData.php: Call to a member function getData() on a non-object (null)?

Details

Request ID
XWfN3gpAMDkAAJ8XuPkAAABU
Request URL
commons.wikimedia.org/w/api.php?format=json&formatversion=2&action=query&titles=Category%3APlay%20Mountain&prop=mapdata&mpdlimit=max&mpdgroups=_4d3f78e5cbfadc4057a015d74536ef07cb4bbab2
Stack Trace
trace
#0 /srv/mediawiki/php-1.34.0-wmf.20/includes/api/ApiQuery.php(250): Kartographer\ApiQueryMapData->execute()
#1 /srv/mediawiki/php-1.34.0-wmf.20/includes/api/ApiMain.php(1595): ApiQuery->execute()
#2 /srv/mediawiki/php-1.34.0-wmf.20/includes/api/ApiMain.php(533): ApiMain->executeAction()
#3 /srv/mediawiki/php-1.34.0-wmf.20/includes/api/ApiMain.php(504): ApiMain->executeActionWithErrorHandling()
#4 /srv/mediawiki/php-1.34.0-wmf.20/api.php(86): ApiMain->execute()
#5 /srv/mediawiki/w/api.php(3): require(string)
#6 {main}
Related Gerrit Patches:
mediawiki/extensions/Kartographer : wmf/1.34.0-wmf.20ApiQueryMapData: Fix PHP fatal when ParserOutput has no map data
mediawiki/extensions/Kartographer : masterApiQueryMapData: Fix PHP fatal when ParserOutput has no map data

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 29 2019, 2:42 PM
Mholloway added a subscriber: Mholloway.EditedAug 29 2019, 4:56 PM

This (and T231542 and T231554) should probably be UBN if they're blocking the train, no? (But I don't seem to have the option to change priority at the moment (?))

MSantos added a subscriber: MSantos.EditedAug 29 2019, 5:08 PM

We should probably revert https://gerrit.wikimedia.org/r/c/mediawiki/extensions/Kartographer/+/531159 since it seems that all bugs are related to it.

EDIT: and address the bugs with more time and testing.
EDIT2: related to all Kartographer ones at least

It's a duplicate bug.

Jdforrester-WMF triaged this task as Unbreak Now! priority.Aug 29 2019, 8:16 PM
Jdforrester-WMF changed the subtype of this task from "Production Error" to "Task".
Restricted Application added a subscriber: Liuxinyu970226. · View Herald TranscriptAug 29 2019, 8:17 PM
This comment was removed by Agusbou2015.

Change 533551 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/Kartographer@master] ApiQueryMapData: Fix PHP fatal when ParserOutput has no map data

https://gerrit.wikimedia.org/r/533551

Catrope claimed this task.Aug 30 2019, 4:21 PM

Change 533551 merged by jenkins-bot:
[mediawiki/extensions/Kartographer@master] ApiQueryMapData: Fix PHP fatal when ParserOutput has no map data

https://gerrit.wikimedia.org/r/533551

Change 533577 had a related patch set uploaded (by Jforrester; owner: Catrope):
[mediawiki/extensions/Kartographer@wmf/1.34.0-wmf.20] ApiQueryMapData: Fix PHP fatal when ParserOutput has no map data

https://gerrit.wikimedia.org/r/533577

Change 533577 merged by jenkins-bot:
[mediawiki/extensions/Kartographer@wmf/1.34.0-wmf.20] ApiQueryMapData: Fix PHP fatal when ParserOutput has no map data

https://gerrit.wikimedia.org/r/533577

Mentioned in SAL (#wikimedia-operations) [2019-08-30T19:33:50Z] <jforrester@deploy1001> Synchronized php-1.34.0-wmf.20/extensions/Kartographer/includes/ApiQueryMapData.php: T231561 UBN fix for PHP fatal when ParserOutput has no map data (duration: 00m 56s)

Jdforrester-WMF closed this task as Resolved.Aug 30 2019, 7:34 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

This should now be fixed.