Page MenuHomePhabricator

GrowthExperiments not loading extension.json properly
Closed, ResolvedPublicBUG REPORT

Description

Steps to Reproduce: before 0ff60d1 (a hotfix), open help panel at any wiki that has custom links

Actual Results: Site help was displayed as the first link.

Expected Results: No site help was displayed

Impact: Not known. Some users saw a bad link at prominent place. Noticed by @Urbanecm when demoing, hotfixed shortly after that.

Note: extension.json caused this problem. 5ef7faf changed default set of links from [] to Project:Help, in english. However, due to (something), that displayed at all wikis. @Urbanecm created 0ff60d1, a hotfix, to mitigate that. Deployed on September, 03, European evening, SAL entry

Event Timeline

Urbanecm created this task.Tue, Sep 3, 7:21 PM
Restricted Application added a project: Growth-Team. · View Herald TranscriptTue, Sep 3, 7:21 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Urbanecm triaged this task as Low priority.Tue, Sep 3, 7:27 PM
Urbanecm updated the task description. (Show Details)

Mitigated => low

Pinging a few involved people.

@Tgr (merged patch) @Catrope (consulted with him after hotfixing) @kostajh (created the patch that seems to broke this) to investigate further and implement a longer-term solution.

@MMiller_WMF @nettrom_WMF to discuss real impact and how important mitigations to prevent this in the future are.

@Urbanecm thank you for filing this and for the hotfix. You've set this to in progress, does that mean you're working on it? If so, please claim the task.

Change 534233 had a related patch set uploaded (by Kosta Harlan; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@master] Set correct merge strategy for help panel links

https://gerrit.wikimedia.org/r/534233

kostajh claimed this task.Tue, Sep 3, 8:52 PM
kostajh moved this task from In Progress to Code Review on the Growth-Team (Current Sprint) board.

Change 534240 had a related patch set uploaded (by Catrope; owner: Catrope):
[operations/mediawiki-config@master] Revert "[bugfix] Growth experiments not loading conf properly"

https://gerrit.wikimedia.org/r/534240

Change 534233 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@master] Set correct merge strategy for help panel links

https://gerrit.wikimedia.org/r/534233

@Urbanecm thank you for filing this and for the hotfix. You've set this to in progress, does that mean you're working on it? If so, please claim the task.

No, that the issue-solving is in progress. I solved the immediate issue by deploying a configuration change, which is a hack, but it solves the issue (extensionfunctions), see 0ff60d1. Not logged here, because I deployed before filling any task, and also before uploading to gerrit.

So, I was working on it, and I'm not now. The matter this task is about is in progress, but no one works on it ATM. Maybe "Ready for development" would be more appropriate?

Change 534242 had a related patch set uploaded (by Catrope; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@wmf/1.34.0-wmf.21] Set correct merge strategy for help panel links

https://gerrit.wikimedia.org/r/534242

Change 534243 had a related patch set uploaded (by Catrope; owner: Kosta Harlan):
[mediawiki/extensions/GrowthExperiments@wmf/1.34.0-wmf.20] Set correct merge strategy for help panel links

https://gerrit.wikimedia.org/r/534243

Filled T231947 to decide about testing this.

Change 534240 merged by jenkins-bot:
[operations/mediawiki-config@master] Revert "[bugfix] Growth experiments not loading conf properly"

https://gerrit.wikimedia.org/r/534240

Change 534243 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@wmf/1.34.0-wmf.20] Set correct merge strategy for help panel links

https://gerrit.wikimedia.org/r/534243

Change 534242 merged by jenkins-bot:
[mediawiki/extensions/GrowthExperiments@wmf/1.34.0-wmf.21] Set correct merge strategy for help panel links

https://gerrit.wikimedia.org/r/534242

Mentioned in SAL (#wikimedia-operations) [2019-09-03T23:52:49Z] <niharika29@deploy1001> Synchronized php-1.34.0-wmf.20/extensions/GrowthExperiments/: Set correct merge strategy for help panel links T231935 (duration: 00m 56s)

Mentioned in SAL (#wikimedia-operations) [2019-09-03T23:53:58Z] <niharika29@deploy1001> Synchronized php-1.34.0-wmf.21/extensions/GrowthExperiments/: Set correct merge strategy for help panel links T231935 (duration: 00m 55s)

Mentioned in SAL (#wikimedia-operations) [2019-09-03T23:56:04Z] <niharika29@deploy1001> Synchronized wmf-config/InitialiseSettings.php: Revert - [bugfix]Growth experiments not loading conf properly T231935 (duration: 00m 55s)

Mentioned in SAL (#wikimedia-operations) [2019-09-03T23:57:28Z] <niharika29@deploy1001> Synchronized wmf-config/CommonSettings.php: Revert - [bugfix]Growth experiments not loading conf properly T231935 (duration: 00m 55s)

Etonkovidova closed this task as Resolved.Wed, Sep 4, 9:44 PM