Page MenuHomePhabricator

Monthly convert: set hide cookie when modal loads
Closed, ResolvedPublic

Description

Traditional credit card one-time donor checkout: donor enters credit card info in payments wiki iframe, submits, and then is redirected to TY page.
Monthly convert equivalent: donor enters credit card info in payments wiki iframe, submits, and then gets monthly convert modal. The donor needs to interact with the modal (by closing it, choosing Yes or No, or submitting a custom monthly amount) to get the TY page redirect.

And we set the banner hide cookie on the TY page! So there's the chance that some one-time cc donors will exit the process before the TY page.

Can we set the hide cookie when the monthly convert modal appears? We can leave it on the TY page, too.

Event Timeline

spatton created this task.Oct 10 2019, 7:01 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 10 2019, 7:01 PM

@Jgreen and @Dwisehaupt Do you think we can do this without running afoul of PCI? This would mean adding to the payment result landing page on payments-wiki a bunch of <img> tags pointing to the Special:HideBanners URLs of various wikimedia projects.

The issue is that some donors who were previously being redirected straight to the Thank You page (which has those <img> tags) are now being asked to convert to monthly donations while still on payments-wiki. I guess some are closing the browser window instead of clicking on the X and never getting to the TY page, thus never getting their hide cookies set.

Ejegg added a comment.Oct 16 2019, 8:15 PM

OK, so sounds like this probably ISN'T a PCI problem - since it's img tags and not script, and since it's happening well past the step where we open the iframe to show the credit card form. In that case, it's just a matter of copying the <img> tags from the TY page to the monthly convert template.

@spatton FYI^^^ this is in the sprint now but I don't have an eta just yet.

jgleeson claimed this task.Oct 21 2019, 7:49 PM
jgleeson moved this task from Backlog to Doing on the Fundraising Sprint Usual Subscripts board.

Change 545326 had a related patch set uploaded (by Jgleeson; owner: Jgleeson):
[mediawiki/extensions/DonationInterface@master] Add hide cookies to monthly convert modal

https://gerrit.wikimedia.org/r/545326

Change 545326 merged by jenkins-bot:
[mediawiki/extensions/DonationInterface@master] Add hide cookies to monthly convert modal

https://gerrit.wikimedia.org/r/545326

This is now live.

Awesome @jgleeson, @DStrine : thank you!

DStrine closed this task as Resolved.Nov 12 2019, 9:14 PM