Page MenuHomePhabricator

Step 1: bail-out path for deprecated main snaks (impact: medium)
Closed, ResolvedPublic8 Estimated Story Points

Description

As an editor I want to be able to edit all data that is shown to me in the Bridge.

Problem:
We don't support editing of all ranks. We need to allow a bail-out to Wikidata for this case so the editors can still edit this data.

Screenshots/mockups:

BDD
GIVEN a statement with a deprecated value
WHEN trying to edit it
THEN a message is shown leading the editor to edit on the repository instead

Acceptance criteria:

  • trying to edit a statement with a deprecated value results in a screen telling the editor to go to the repository
  • hierarchy of bail-outs is datatype -> multiple values -> special value -> rank

Event Timeline

Restricted Application added a project: Wikidata. · View Herald TranscriptNov 19 2019, 3:32 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Lydia_Pintscher triaged this task as High priority.
Lydia_Pintscher moved this task from Backlog to Needs work on the Wikidata-Bridge board.

Assigning to Charlie to figure out how the interaction should work.

Lydia_Pintscher renamed this task from Wikidata Ticket Template to bail-out path for individual snaks.Nov 19 2019, 3:35 PM
Charlie_WMDE updated the task description. (Show Details)Nov 28 2019, 3:19 PM
Charlie_WMDE updated the task description. (Show Details)Dec 2 2019, 9:28 AM
Charlie_WMDE updated the task description. (Show Details)
Lydia_Pintscher renamed this task from bail-out path for individual snaks to Step 1: bail-out path for individual snaks.Dec 5 2019, 1:11 PM

Based on last weeks discussion: rewrite this to handle these cases in the same way we handle not being able to edit the data type of the main snak.

Lydia_Pintscher renamed this task from Step 1: bail-out path for individual snaks to Step 1: bail-out path for novalue/somevalue in the main snak and deprecated main snaks.Dec 8 2019, 12:08 PM
Lydia_Pintscher renamed this task from Step 1: bail-out path for novalue/somevalue in the main snak and deprecated main snaks to Step 1: bail-out path for novalue/somevalue in the main snak and deprecated main snaks (impact: medium).Dec 8 2019, 1:21 PM
Addshore moved this task from incoming to in progress on the Wikidata board.Dec 11 2019, 11:47 AM
Charlie_WMDE updated the task description. (Show Details)EditedJan 10 2020, 1:44 PM

@Lydia_Pintscher please have a look if this is ready for story writing

Jep :)
One issue in the text for the deprecated path: It says the Property is deprecated but what is actually deprecated is the value. (Deprecating a Property means the editor is no longer supposed to use that particular Property in any statement.)

@Lydia_Pintscher fixed. thank you for the feedback.

Lydia_Pintscher renamed this task from Step 1: bail-out path for novalue/somevalue in the main snak and deprecated main snaks (impact: medium) to Step 1: bail-out path for deprecated main snaks (impact: medium).Jan 14 2020, 1:09 PM
Lydia_Pintscher updated the task description. (Show Details)
Lydia_Pintscher set the point value for this task to 8.
Charlie_WMDE removed Charlie_WMDE as the assignee of this task.Jan 28 2020, 12:15 PM
Charlie_WMDE added a subscriber: Charlie_WMDE.

Should the heading really be “Editing the value for $property is not supported”? That’s the same heading as for unsupported datatypes (T235753), but in this case, the problem isn’t the property, it’s the particular statement.

Should the heading really be “Editing the value for $property is not supported”? That’s the same heading as for unsupported datatypes (T235753), but in this case, the problem isn’t the property, it’s the particular statement.

In theory something to think about. But there's an upcoming ticket (not created yet) with text changes to the bail-out paths so I'd wait with discussing any further changes until we have it in story writing.

Change 570634 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[mediawiki/extensions/Wikibase@master] bridge: WIP: show property labels in bailout components

https://gerrit.wikimedia.org/r/570634

Change 570634 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] bridge: show property labels in bailout components

https://gerrit.wikimedia.org/r/570634

Change 570921 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[mediawiki/extensions/Wikibase@master] bridge: fix vertical marging of bailout heading

https://gerrit.wikimedia.org/r/570921

Change 570921 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] bridge: fix vertical marging of bailout heading

https://gerrit.wikimedia.org/r/570921

Charlie_WMDE closed this task as Resolved.Feb 10 2020, 12:46 PM
Charlie_WMDE claimed this task.
Charlie_WMDE moved this task from Verification to Done on the Wikidata-Bridge-Sprint-13 board.

looks good!