Page MenuHomePhabricator

VE: <references /> tag should be followed by a carriage return when inserted (as block element format)
Closed, ResolvedPublic

Description

It should not be possible to add some text on the same line than references tag using visual editor.

To reproduce:

  1. Edit/Create a page with visual editor.
  2. Type some text on a new line.
  3. Insert > References list.
  4. Press right arrow to put your cursor on the new line after reference list.
  5. Type other text.
  6. Save (or preview changes).

Actual wikitext:

some text
<references />other text

Expected wikitext:

some text
<references />
other text

Details

Related Gerrit Patches:
mediawiki/services/parsoid : masterSerialize reference tags by themselves on a line

Event Timeline

Pols12 created this task.Jan 11 2020, 3:31 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 11 2020, 3:31 PM
JTannerWMF moved this task from To Triage to External and Administrivia on the VisualEditor board.
JTannerWMF added a subscriber: JTannerWMF.

We believe this is something that would potentially be changed in Parsoid, so we are adding the Parsing team to this task.

Change 564743 had a related patch set uploaded (by Arlolra; owner: Arlolra):
[mediawiki/services/parsoid@master] Serialize reference tags by themselves on a line

https://gerrit.wikimedia.org/r/564743

matmarex added a subscriber: matmarex.

We believe this is something that would potentially be changed in Parsoid, so we are adding the Parsing team to this task.

Thanks @JTannerWMF. In the future, can you add the project tag (Parsoid, since that is what you are mostly filing bugs against) instead of the team tag (Parsing-Team)?

Change 564743 merged by jenkins-bot:
[mediawiki/services/parsoid@master] Serialize reference tags by themselves on a line

https://gerrit.wikimedia.org/r/564743

Arlolra closed this task as Resolved.Jan 17 2020, 4:34 PM
Arlolra claimed this task.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJan 17 2020, 4:34 PM

I still reproduce on en.wikipedia.beta.wmflabs.org

I still reproduce on en.wikipedia.beta.wmflabs.org

This hasn't been deployed yet (not even to beta).

Sorry, I thought all merged patch were automatically deployed to beta.

Reedy added a subscriber: Reedy.Sat, Jan 18, 5:32 PM

Sorry, I thought all merged patch were automatically deployed to beta.

Only really mediawiki changes (skins, extensions) and MW config are automatically deployed

Mentioned in SAL (#wikimedia-operations) [2020-01-22T21:28:34Z] <arlolra> Updated Parsoid to 7390988 (T242513, T243008, T241146)