Page MenuHomePhabricator

[Investigate] Why does parser detect a comment when a link to a person's user page, talk page or contributions page is missing.
Closed, ResolvedPublic

Description

Actual behavior

  1. Visit: https://nl.wikipedia.org/wiki/Overleg_gebruiker:213.124.17.165?dtenable=1 or https://nl.wikipedia.org/wiki/Overleg_gebruiker:78.21.12.96?dtenable=1
  2. Observe a list of vandalistic edits this person has made within the section titled "Dossier 2018-2019"

⚠️ 3. Observe reply links ("Antwoorden") are being appended to each of these vandalistic edit list items despite them not containing a link to a person's user page, talk page or contributions page.

Expected behavior

  1. Visit: https://nl.wikipedia.org/wiki/Overleg_gebruiker:213.124.17.165?dtenable=1 or https://nl.wikipedia.org/wiki/Overleg_gebruiker:78.21.12.96?dtenable=1
  2. Observe a list of vandalistic edits this person has made within the section titled "Dossier 2018-2019"

✅ 3. Observe reply links ("Antwoorden") are not being appended to each of these vandalistic edit list items

Done

  • Document why the "Actual behavior" is happening: is this a bug in the comment parser? Is this a use case we have not yet designed for? See: T245692#5899556
  • Document what would be involved in fixing this behavior. Documenting the approach not needed. Why? Issue is fixed. See: T245692#5912210

Additional context: T244432#5895971

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 19 2020, 11:53 PM
ppelberg updated the task description. (Show Details)Feb 19 2020, 11:57 PM

This happens because we try to recognize comments with a timestamp but without a signature. This was meant to allow replying to announcements posted by some bots, e.g. https://en.wikipedia.org/wiki/Wikipedia:Village_pump_(technical)/Archive_179#Tech_News:_2020-06 (note how the initial comment ends with "20:04, 3 February 2020 (UTC)" and no signature). But it seems like it will cause issues more often than it helps, so we should probably only detect comments with real signatures.

This happens because we try to recognize comments with a timestamp but without a signature. This was meant to allow replying to announcements posted by some bots, e.g. https://en.wikipedia.org/wiki/Wikipedia:Village_pump_(technical)/Archive_179#Tech_News:_2020-06 (note how the initial comment ends with "20:04, 3 February 2020 (UTC)" and no signature). But it seems like it will cause issues more often than it helps, so we should probably only detect comments with real signatures.

+1 to adapting the parser to, "...only detect comments with real signatures."

ppelberg updated the task description. (Show Details)Feb 20 2020, 12:30 AM
matmarex triaged this task as High priority.Feb 20 2020, 6:20 PM

Change 573773 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/DiscussionTools@master] Only detect comments with real signatures

https://gerrit.wikimedia.org/r/573773

Change 573773 merged by jenkins-bot:
[mediawiki/extensions/DiscussionTools@master] Only detect comments with real signatures

https://gerrit.wikimedia.org/r/573773

JTannerWMF moved this task from Inbox to High Priority on the Editing QA board.
Ryasmeen edited projects, added Verified; removed Editing QA.
ppelberg closed this task as Resolved.Mar 5 2020, 7:29 PM
ppelberg updated the task description. (Show Details)
ppelberg updated the task description. (Show Details)