Page MenuHomePhabricator

Can not "Publish changes" - RadioInput selection not detected in IE11
Closed, ResolvedPublic5 Estimated Story PointsBUG REPORT

Description

Steps to Reproduce:
dependent on environment: e.g. Win 7, IE11

Actual Results:

GIVEN a healthy data bridge editing window
WHEN  having changed the statement value (string input) & picked the edit decision (radio button)
THEN  the "Publish changes" button remains disabled

Expected Results:

GIVEN a healthy data bridge editing window
WHEN  having changed the statement value (string input) & picked the edit decision (radio button)
THEN  the "Publish changes" button becomes enabled (blue)

Info

Event Timeline

Restricted Application added a project: Wikidata. · View Herald TranscriptApr 3 2020, 3:08 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

In Firefox, any kind of selection seems to trigger listeners for all of input, change, and click, so it looks like the browser is supposed to fake a click event even for keyboard input. (Selecting a different input doesn’t trigger any event in the deselected input.) However, click also fires when clicking again on the already selected input, whereas change doesn’t, so if both work in IE11, then change seems preferable to me.

@Lydia_Pintscher This would need to be prioritized accordingly to ensure that bridge works in internet explorer as required by https://www.mediawiki.org/wiki/Compatibility#Browser_support_matrix

Pablo-WMDE updated the task description. (Show Details)May 13 2020, 10:42 AM
Pablo-WMDE set the point value for this task to 5.May 13 2020, 10:44 AM
Pablo-WMDE edited projects, added Wikidata-Bridge-Sprint-20; removed Wikidata-Bridge.

Automatic release deployment should have our back since v0.1.8 (https://gerrit.wikimedia.org/r/593491) as implemented in T245497 + T245826

Change 596636 had a related patch set uploaded (by Lucas Werkmeister (WMDE); owner: Lucas Werkmeister (WMDE)):
[wikibase/vuejs-components@master] Make RadioInput work in IE11

https://gerrit.wikimedia.org/r/596636

Change 596636 merged by jenkins-bot:
[wikibase/vuejs-components@master] Make RadioInput work in IE11

https://gerrit.wikimedia.org/r/596636

Change 597277 had a related patch set uploaded (by Pablo Grass (WMDE); owner: Pablo Grass (WMDE)):
[mediawiki/extensions/Wikibase@master] bridge: update to latest @wmde/wikibase-vuejs-components

https://gerrit.wikimedia.org/r/597277

Change 597277 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] bridge: update to latest @wmde/wikibase-vuejs-components

https://gerrit.wikimedia.org/r/597277

Lucas_Werkmeister_WMDE closed this task as Resolved.May 19 2020, 2:23 PM

Verified in a Win10 VM that Data Bridge is usable now.