Page MenuHomePhabricator

[Regression pre-wmf.32] The Reply box is opening up automatically after posting a reply
Closed, ResolvedPublic

Description

Steps to replicate:

  1. Open any talk page
  2. Click Reply link next to any comment
  3. Type a reply and post it

Observe that, another reply box is immediately opening up under the newly added comment.

Browser: Chrome.

Environment: Beta

Event Timeline

Ryasmeen created this task.May 7 2020, 10:50 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 7 2020, 10:50 PM

It looks like we don't clear the auto-save anymore when posting or discarding the reply. This used to work, but it was actually a bit fragile now that I think of it, I noted that:

It wasn't clear to me initially how discarding the autosaved version works, since I didn't see any code for that. It turns out that it works because .teardown() calls .clear() which calls .setValue(''), and that empties the autosaved text too.

Ed's work on switching editors refactored a bunch of things in teardown, maybe it broke this.

Ed's work on switching editors refactored a bunch of things in teardown, maybe it broke this.

Yes, we started detaching the 'change' event sooner...

Change 595239 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/DiscussionTools@master] Manually clear out session storage on teardown

https://gerrit.wikimedia.org/r/595239

Change 595239 merged by jenkins-bot:
[mediawiki/extensions/DiscussionTools@master] Manually clear out session storage on teardown

https://gerrit.wikimedia.org/r/595239

Ryasmeen edited projects, added Verified; removed Editing QA.May 8 2020, 11:22 PM
ppelberg closed this task as Resolved.Jun 1 2020, 1:46 AM
ppelberg claimed this task.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJun 1 2020, 1:46 AM