Page MenuHomePhabricator

Changing a value with unit: label and unit name mixed
Closed, ResolvedPublicBUG REPORT

Description

Changing a value with unit: label and unit name mixed, see screenshot.

Browser. Firefox 77

Try to change the length on https://commons.wikimedia.org/wiki/File:Ship_Josephine_ENI_05109590_-_on_Spree,_Berlin-7662.jpg

Event Timeline

Raymond created this task.Jun 5 2020, 3:39 PM
Restricted Application added a project: Wikidata. · View Herald TranscriptJun 5 2020, 3:39 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Ramsey-WMF added a subscriber: Ramsey-WMF.

Bug confirmed on Chrome.

Ramsey-WMF changed the subtype of this task from "Task" to "Bug Report".Jun 5 2020, 5:59 PM

@Ramsey-WMF or @mwilliams, do either of you have a mockup of how the editing UI is supposed to look in this situation? I can see that some absolutely-positioned label text for "unit" and "metre" is colliding here, but I want to make sure I understand what is supposed to go where before fixing.

mwilliams added a comment.EditedJun 8 2020, 8:01 PM

@egardner It seems like it is supposed to look like this (height example):

The spacing there feels a bit weird though, I'd expect something like "Unit: Metre" since they look unrelated or two different things currently.

egardner added a comment.EditedJun 8 2020, 9:13 PM

Ok, I think that the labelPosition: "before" option that's being set for the QuantityInputWidget's EntityAutoCompleteInputWidget child (QuantityInputWidget.js L34) might be the source of this problem.

By removing that option, you get the layout that you see below. Does this seem correct? (Disregard my nonsensical local data)

Looks much better to me!

Change 603676 had a related patch set uploaded (by Eric Gardner; owner: Eric Gardner):
[mediawiki/extensions/WikibaseMediaInfo@master] Fix overlapping text in qualifier quantity input

https://gerrit.wikimedia.org/r/603676

Change 603676 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Fix overlapping text in qualifier quantity input

https://gerrit.wikimedia.org/r/603676

Ramsey-WMF closed this task as Resolved.Jun 22 2020, 5:48 PM

tested on production and the text no longer overlaps