Page MenuHomePhabricator

Rename "ombudsman" global group to "ombuds"
Closed, ResolvedPublic

Description

There has been no WMF board objection, and an associated majority consensus to rename the "ombudsman" global group to the gender neutral "ombuds".

This appears to need a systems change and as a global group will be visible in all projects.

Ref:

Event Timeline

Fae created this task.Jun 24 2020, 6:38 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJun 24 2020, 6:38 PM
Fae updated the task description. (Show Details)Jun 24 2020, 6:42 PM

I can confirm that the board discussed this proposal and their was only support for making the change in question.

Aklapper renamed this task from Rename ombudsman group to Rename "ombudsman" global group to "ombuds".Jun 24 2020, 7:14 PM

Renaming of global groups is done via the on-wiki interface, and does not require a system change. Suggest closing as invalid

Reedy added a subscriber: Reedy.

Renaming of global groups is done via the on-wiki interface, and does not require a system change. Suggest closing as invalid

Message keys and values need renaming in WikimediaMessages

	"group-ombudsman": "Ombudsmen",
	"group-ombudsman-member": "{{GENDER:$1|ombudsman}}",
	"grouppage-ombudsman": "m:Ombudsman commission",
Fae added a comment.Jun 28 2020, 10:25 AM

Renaming of global groups is done via the on-wiki interface, and does not require a system change. Suggest closing as invalid

Phabricator use is encouraged for other types of Wikimedia project beyond software changes, such as Comms initiatives. Coordinating this change that might only be an email list name change and a wiki interface config is still part of how we want Phabricator to be of value and helps serve as a record of what was changed and can be quoted in other minor changes to avoid accidental systemic bias.

Majavah claimed this task.EditedJun 28 2020, 10:26 AM

Feel free to correct me if I'm wrong, but afaik in this case we need to 1) add message keys for group-ombuds 2) wait for the new messages to go out with the train everywhere 3) rename the group on-wiki and 4) after that we can remove old message keys for group-ombudsmen (which should not be renamed as the content will change)

Restricted Application added a project: User-Majavah. · View Herald TranscriptJun 28 2020, 10:26 AM

Change 608210 had a related patch set uploaded (by Majavah; owner: Majavah):
[mediawiki/extensions/WikimediaMessages@master] Add messages for "ombuds" group

https://gerrit.wikimedia.org/r/c/mediawiki/extensions/WikimediaMessages/ /608210

Reedy added a comment.Jun 28 2020, 1:28 PM

Feel free to correct me if I'm wrong, but afaik in this case we need to 1) add message keys for group-ombuds 2) wait for the new messages to go out with the train everywhere 3) rename the group on-wiki and 4) after that we can remove old message keys for group-ombudsmen (which should not be renamed as the content will change)

Yup

Interestingly, some translations (ie at) have already made it gender neutral :)

	"group-ombudsman": "Ombudspersonat",

Similar for German, and some just use "mediator"

Change 608210 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@master] Add messages for "ombuds" group

https://gerrit.wikimedia.org/r/c/mediawiki/extensions/WikimediaMessages/ /608210

Jony added a subscriber: Jony.Jul 2 2020, 11:10 AM
Urbanecm closed this task as Resolved.Jul 3 2020, 7:47 AM
Urbanecm added a subscriber: Urbanecm.

A fellow steward just did the global group change. CLosing as resolved.

Majavah reopened this task as Open.Jul 3 2020, 8:15 AM

Not yet, since we have to get rid of the old message keys.

Change 609389 had a related patch set uploaded (by Majavah; owner: Majavah):
[mediawiki/extensions/WikimediaMessages@master] Remove messages for "ombudsman" global group

https://gerrit.wikimedia.org/r/609389

Reedy closed this task as Resolved.Jul 7 2020, 10:46 PM

Change 609389 merged by jenkins-bot:
[mediawiki/extensions/WikimediaMessages@master] Remove messages for "ombudsman" global group

https://gerrit.wikimedia.org/r/609389