Page MenuHomePhabricator

Make Google Translate the default for Ukrainian instead of Apertium
Closed, ResolvedPublic

Description

Recently we have noticed a low-quality translation made via ContentTranslation tool by a non-Ukrainian speaker: https://uk.wikipedia.org/w/index.php?title=Боспієк&oldid=29142016

The text has an unusual number of words which either come from Russian, do not exist in either of languages or even some hashtags instead of words:

On the screenshot (cc by sa 3.0., list of authors in the history) with the pink colour I have highlighted the words that do not exist in Ukrainian (Russian words, words that do not use Ukrainian alphabet, words that do not exist in either language, hashtags), and with wiggly grey line I have highlighted the words that are in wrong grammatical case and would have to be manually fixed. I did not highlight subtler mistakes a competent Ukrainian speaker would fix to make the text a natural sounding Ukrainian.

The quality of translation demonstrated is not satisfying. Google and Yandex translations are not perfect, but mostly they at least do not insert words that do not exist or even cannot possibly exist in Ukrainian (such as using letters outside Ukrainian alphabet or # symbol).

The problem is that Apertium is now the default translation system when translating from ru to uk (is it because it is first alphabetically?):

Please either make another system the default one or disable Apertium altogether until it provides production ready translation quality.

Event Timeline

Base created this task.Aug 8 2020, 6:39 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 8 2020, 6:39 PM

Related (although not for Content Translation): T216319.

Please either make another system the default one or disable Apertium altogether until it provides production ready translation quality.

We can easily make other system the default. In your experience which one provides better results Google or Yandex?

Ata added a comment.Aug 11 2020, 5:11 PM

Google was default one before, it would be ok to make it one again.

Pginer-WMF renamed this task from Disable or make non-default Apertium translation for Ukrainian to Make Google Translate the default for Ukrainian instead of Apertium.Aug 12 2020, 10:22 AM
Pginer-WMF triaged this task as Medium priority.

Google was default one before, it would be ok to make it one again.

Thanks. I updated the title to reflect this. Once the configuration is changed, we'll update when the change becomes visible to users (will depend on review and deployment cycles).

Change 620046 had a related patch set uploaded (by KartikMistry; owner: KartikMistry):
[mediawiki/services/cxserver@master] Make Google Translate the default for ru-uk pair

https://gerrit.wikimedia.org/r/620046

Change 620046 merged by jenkins-bot:
[mediawiki/services/cxserver@master] Make Google Translate the default for ru-uk pair

https://gerrit.wikimedia.org/r/620046

Change 620692 had a related patch set uploaded (by KartikMistry; owner: KartikMistry):
[operations/deployment-charts@master] Update cxserver to 2020-08-17-090424-production

https://gerrit.wikimedia.org/r/620692

Change 620692 merged by jenkins-bot:
[operations/deployment-charts@master] Update cxserver to 2020-08-17-090424-production

https://gerrit.wikimedia.org/r/620692

Mentioned in SAL (#wikimedia-operations) [2020-08-18T09:34:59Z] <kart_> Update cxserver to 2020-08-17-090424-production (T259980)

KartikMistry closed this task as Resolved.Aug 27 2020, 4:39 PM