Page MenuHomePhabricator

[M] Media Search: Auto scroll down upon click of quick view
Closed, ResolvedPublic

Description

Due to MediaWiki and our current design, around 35% of the initial view of a result set is global header stuff, "Search Media", search input, and filters. This isn't a huge deal in general since we know our users will scroll but it does become a problem with quick view and being able to see what is going on and some weird scroll behavior.

Our friends at Google Images get around this by auto scrolling down to the result set anytime you click on a result while the space above is still showing.

The file is too large to attach here, but here is a video of our experience and how Google handles it: https://drive.google.com/file/d/1V0jmxZAmxWrxhhPxUN6n7VXF0KYpThS7/view?usp=sharing

I think a similar scroll down could be beneficial into making our quick view be a bit more usable and useful.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 31 2020, 7:54 PM
CBogen added a subscriber: CBogen.Sep 9 2020, 4:25 PM

@mwilliams, we are assuming this is not wanted for the mobile skin, since that's an overlay - can you confirm?

CBogen renamed this task from Media Search: Auto scroll down upon click of quick view to [M] Media Search: Auto scroll down upon click of quick view.Sep 9 2020, 4:25 PM

@CBogen Yup, desktop only for this one, thanks for clarifying

Change 644335 had a related patch set uploaded (by Anne Tomasevich; owner: Anne Tomasevich):
[mediawiki/extensions/WikibaseMediaInfo@master] Improve UX when clicking on result

https://gerrit.wikimedia.org/r/644335

Change 644335 merged by jenkins-bot:
[mediawiki/extensions/WikibaseMediaInfo@master] Improve UX when clicking on result

https://gerrit.wikimedia.org/r/644335

Etonkovidova added a subscriber: Etonkovidova.

Checked in commons betalabs (see the gif below) - looks identical to Google Images autoscroll. Interesting that Google Images freezes the search bar, so users see the search items all the time when they scroll the screen.

Moving for @mwilliams quick review. If all look correct - please move to Verify in production.

Tested successfully

  • on different browsers
  • on mobile (for possible general regression)

(click on the animated gif)

commons betalabscommons production

Looks good to me!

Etonkovidova closed this task as Resolved.Thu, Jan 7, 1:55 AM