Page MenuHomePhabricator

Create Wikisource in Esperanto
Closed, ResolvedPublic

Description

Author: millosh

Description:
I missed to ask for creation of Wikisource in Esperanto last time.


Version: unspecified
Severity: enhancement

Details

Reference
bz26136

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 11:22 PM
bzimport set Reference to bz26136.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Nov 27 2010, 3:40 AM

I have set up the configuration files but I am unable to create the wiki right now. Will need more time to investigate this:

$ php addwiki.php --wiki eowikisource eo wikisource eowikisource eo.wikisource.org
DB connection error: Unknown database 'eowikisource' (10.0.6.49)

The script seems really bugged since it should not require --wiki in the first place.

bugs wrote:

(In reply to comment #1)

I have set up the configuration files but I am unable to create the wiki right
now. Will need more time to investigate this:
$ php addwiki.php --wiki eowikisource eo wikisource eowikisource
eo.wikisource.org
DB connection error: Unknown database 'eowikisource' (10.0.6.49)
The script seems really bugged since it should not require --wiki in the first
place.

http://wikitech.wikimedia.org/view/Add_a_wiki says you first need to: « Add the database name to all.dblist and pmtpa.dblist. »

I just looked at all.dblist and couldn't find eowikisource -- that's probably what's causing the problem.

jeluf wrote:

Try --wiki=aawiki. As RobH points out in the documentation, the script is a little bit broken and needs this parameter in order to work properly.

james.maximillion wrote:

Does anyone know how much longer this is going to be?

michelcastelobranco wrote:

(In reply to comment #4)

Does anyone know how much longer this is going to be?

Good question, I think this is a record: while eo.wikinews (25774) took nine days, eo.wikisource waits for almost 4 months (and still counting...)! Seriously, if there's something the Esperanto community could do in order to help or explain, please let us know. Maybe the magic conversion (cx|ĉ, gx|ĝ, hx|ĥ, jx|ĵ, sx|ŝ, ux|ŭ)? Or the domain names?

(In reply to comment #5)

(In reply to comment #4)

Does anyone know how much longer this is going to be?

Good question, I think this is a record: while eo.wikinews (25774) took nine
days, eo.wikisource waits for almost 4 months (and still counting...)!
Seriously, if there's something the Esperanto community could do in order to
help or explain, please let us know. Maybe the magic conversion (cx|ĉ, gx|ĝ,
hx|ĥ, jx|ĵ, sx|ŝ, ux|ŭ)? Or the domain names?

It's nothing on your end. The timing on our side is a bit unfortunate, with the person normally doing new wiki creations (RobH) busy with the buildout of the new datacenter.

jeluf wrote:

Your change has been completed.
Please reopen this ticket if anything went wrong.

The following configuration settings have been changed:

Index: InitialiseSettings.php

  • InitialiseSettings.php (revision 1646)

+++ InitialiseSettings.php (working copy)
@@ -181,6 +181,7 @@

'dewikisource' => 'Europe/Berlin',
'dewikiversity' => 'Europe/Berlin',
'dsbwiki' => 'Europe/Berlin',

+ 'eowikisource' => 'UTC',

'etwiki'      => 'Europe/Tallinn',
'etwikibooks'  => 'Europe/Tallinn',
'etwikimedia'  => 'Europe/Tallinn',

You can find the entire config file at
http://noc.wikimedia.org/conf/highlight.php?file=InitialiseSettings.php

jeluf wrote:

This redirect is from your browser cache. Please flush your cache.

sh-3.2$ telnet eo.wikisource.org 80

Trying 208.80.152.2...
Connected to text.pmtpa.wikimedia.org.
Escape character is '^]'.
GET / HTTP/1.0
Host: eo.wikisource.org
User-Agent: JeLuF

HTTP/1.0 301 Moved Permanently
Date: Fri, 18 Mar 2011 20:39:21 GMT
Server: Apache
Cache-Control: s-maxage=1200, must-revalidate, max-age=0
Vary: Accept-Encoding,Cookie
Last-Modified: Fri, 18 Mar 2011 20:39:21 GMT
Location: http://eo.wikisource.org/wiki/%C4%88efpa%C4%9Do

michelcastelobranco wrote:

(In reply to comment #9)

This redirect is from your browser cache. Please flush your cache.

Still redirecting (with cache flushed).

Reedy added a comment.Mar 19 2011, 1:05 AM

Works for me now. Didn't earlier...

james.maximillion wrote:

It's working for me now too.

james.maximillion wrote:

It's redirecting again...

We had to purge some pages from the squid.

http://eo.wikisource.org (NO TRAILING SLASH) was cached with a Location to http://wikisource.org/.

Full headers:

before purge:
$ curl -i http://eo.wikisource.org
HTTP/1.0 301 Moved Permanently
Date: Fri, 18 Mar 2011 09:46:37 GMT
Server: Apache
Location: http://wikisource.org/
Cache-Control: max-age=2592000
Expires: Sun, 17 Apr 2011 09:46:37 GMT
Content-Length: 230
Content-Type: text/html; charset=iso-8859-1
X-Cache: HIT from sq77.wikimedia.org
X-Cache-Lookup: HIT from sq77.wikimedia.org:3128
Age: 104210
X-Cache: HIT from amssq31.esams.wikimedia.org
X-Cache-Lookup: HIT from amssq31.esams.wikimedia.org:3128
X-Cache: MISS from amssq44.esams.wikimedia.org
X-Cache-Lookup: MISS from amssq44.esams.wikimedia.org:80
Connection: close

After purge:

$ curl -i http://eo.wikisource.org
HTTP/1.0 301 Moved Permanently
Date: Sat, 19 Mar 2011 14:43:54 GMT
Server: Apache
Cache-Control: s-maxage=1200, must-revalidate, max-age=0
Vary: Accept-Encoding,Cookie
Last-Modified: Sat, 19 Mar 2011 14:43:54 GMT
Location: http://eo.wikisource.org/wiki/%C4%88efpa%C4%9Do
Content-Length: 0
Content-Type: text/html; charset=utf-8
X-Cache: MISS from sq77.wikimedia.org
X-Cache-Lookup: HIT from sq77.wikimedia.org:3128
Age: 562
X-Cache: HIT from amssq31.esams.wikimedia.org
X-Cache-Lookup: HIT from amssq31.esams.wikimedia.org:3128
X-Cache: MISS from amssq40.esams.wikimedia.org
X-Cache-Lookup: MISS from amssq40.esams.wikimedia.org:80
Connection: close

Closing this bug as the problem with eo.wikisource.org appears to be solved.